summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-05-27 13:55:26 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-05-27 13:55:26 +0200
commitb182941f47c27435e601739f8133942606b51860 (patch)
tree8bfa06474092f437eddf49bc3735a51ae15f0666
parentwww-apps: init work on racktables (diff)
downloadportage-b182941f47c27435e601739f8133942606b51860.tar.xz
sys-apps: Add winexe 0.91 and 1.00
http://sourceforge.net/projects/winexe/
-rw-r--r--sys-apps/winexe/Manifest5
-rw-r--r--sys-apps/winexe/files/filesdir.patch11
-rw-r--r--sys-apps/winexe/winexe-0.91.ebuild42
-rw-r--r--sys-apps/winexe/winexe-1.00.ebuild42
4 files changed, 100 insertions, 0 deletions
diff --git a/sys-apps/winexe/Manifest b/sys-apps/winexe/Manifest
new file mode 100644
index 00000000..86abfcf7
--- /dev/null
+++ b/sys-apps/winexe/Manifest
@@ -0,0 +1,5 @@
+AUX filesdir.patch 505 RMD160 85d9166ef29befc5a8e4638ee6b78b88b2f8ffc3 SHA1 920f20086ca1af5ccabdae0ab2ee302814319d12 SHA256 bac1d7e1ac0b81a35e3edc8bc24718b8d31913a79b7c860001e60de73e3c736b
+DIST winexe-0.91.tar.gz 21910571 RMD160 cc749d27c4c067c63fc9e9d49f2eeb3e84de8d4b SHA1 50fe37cb21045f739a650747e91e6b64ed39edbe SHA256 421c4a466f974d393efab92ae092225e96558a676f3629a56e21b4a3e5c67a66
+DIST winexe-1.00.tar.gz 21931368 RMD160 c265410f80edced5a9ae6ae4df8c9a40a93669e8 SHA1 bdb598745953fcad3a9b6bba8f728c2b714a7aeb SHA256 99238bd3e1c0637041c737c86a05bd73a9375abc9794dca71d2765e22d87537e
+EBUILD winexe-0.91.ebuild 774 RMD160 28868cacd3e8d4c024ab78cda0aa2e8a20643c37 SHA1 608af9d174ed36615a6859783715ba6204b397a8 SHA256 3c3dbd44a1015e0e47ff3e8818935456362c908b9267392fbece726421ef9a73
+EBUILD winexe-1.00.ebuild 774 RMD160 28868cacd3e8d4c024ab78cda0aa2e8a20643c37 SHA1 608af9d174ed36615a6859783715ba6204b397a8 SHA256 3c3dbd44a1015e0e47ff3e8818935456362c908b9267392fbece726421ef9a73
diff --git a/sys-apps/winexe/files/filesdir.patch b/sys-apps/winexe/files/filesdir.patch
new file mode 100644
index 00000000..d9683893
--- /dev/null
+++ b/sys-apps/winexe/files/filesdir.patch
@@ -0,0 +1,11 @@
+--- winexe/service.c.original 2010-09-08 12:57:03.000000000 +0200
++++ winexe/service.c 2010-09-08 12:57:36.000000000 +0200
+@@ -15,7 +15,7 @@
+ #define SERVICE_DEMAND_START (0x00000003)
+ #define SERVICE_ERROR_NORMAL (0x00000001)
+ #define SERVICE_CONTROL_STOP (0x00000001)
+-#define NT_STATUS_SERVICE_DOES_NOT_EXIST NT_STATUS(0xc0000424)
++#define NT_STATUS_SERVICE_DOES_NOT_EXIST NT_STATUS(0xc00000424)
+ #include "system/filesys.h"
+ #include "libcli/libcli.h"
+ #include "libcli/smb_composite/smb_composite.h"
diff --git a/sys-apps/winexe/winexe-0.91.ebuild b/sys-apps/winexe/winexe-0.91.ebuild
new file mode 100644
index 00000000..939060ca
--- /dev/null
+++ b/sys-apps/winexe/winexe-0.91.ebuild
@@ -0,0 +1,42 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+inherit eutils flag-o-matic
+
+DESCRIPTION="winexe remotely executes commands on WindowsNT/2000/XP/2003 systems"
+HOMEPAGE="http://sourceforge.net/projects/winexe"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls"
+
+DEPEND="dev-libs/cyrus-sasl
+ gnutls? ( net-libs/gnutls )
+ dev-libs/popt"
+RDEPEND="${DEPEND}"
+
+S="${S}/source4"
+
+src_prepare () {
+ epatch "${FILESDIR}/filesdir.patch"
+}
+
+src_configure () {
+ ./autogen.sh || die "autogen failed"
+ econf \
+ --enable-fhs \
+ $(use_enable gnutls) \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake basics bin/winexe \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin bin/winexe
+}
diff --git a/sys-apps/winexe/winexe-1.00.ebuild b/sys-apps/winexe/winexe-1.00.ebuild
new file mode 100644
index 00000000..939060ca
--- /dev/null
+++ b/sys-apps/winexe/winexe-1.00.ebuild
@@ -0,0 +1,42 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+inherit eutils flag-o-matic
+
+DESCRIPTION="winexe remotely executes commands on WindowsNT/2000/XP/2003 systems"
+HOMEPAGE="http://sourceforge.net/projects/winexe"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls"
+
+DEPEND="dev-libs/cyrus-sasl
+ gnutls? ( net-libs/gnutls )
+ dev-libs/popt"
+RDEPEND="${DEPEND}"
+
+S="${S}/source4"
+
+src_prepare () {
+ epatch "${FILESDIR}/filesdir.patch"
+}
+
+src_configure () {
+ ./autogen.sh || die "autogen failed"
+ econf \
+ --enable-fhs \
+ $(use_enable gnutls) \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake basics bin/winexe \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin bin/winexe
+}