summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2013-05-29 01:47:22 +0200
committerBertrand Jacquin <beber@meleeweb.net>2013-05-29 01:47:22 +0200
commitafb53049d39c21cb917df6912792f41c4051b01a (patch)
tree4b0a6a6086c0b5d53e90531a59fd1888f176b662
parentnet-misc/openvpn: migrate to EAPI 4 (diff)
downloadportage-afb53049d39c21cb917df6912792f41c4051b01a.tar.xz
net-dialup/rp-pppoe: remove prepalldocs and addpredict fix quotes
-rw-r--r--net-dialup/rp-pppoe/Manifest2
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.10-r1.ebuild16
2 files changed, 7 insertions, 11 deletions
diff --git a/net-dialup/rp-pppoe/Manifest b/net-dialup/rp-pppoe/Manifest
index b68f91ea..6e6707b2 100644
--- a/net-dialup/rp-pppoe/Manifest
+++ b/net-dialup/rp-pppoe/Manifest
@@ -9,5 +9,5 @@ AUX rp-pppoe-3.10-session-offset.patch 832 SHA256 66499b084aab890c61399c703e21ba
AUX rp-pppoe-3.10-username-charset.patch 1950 SHA256 1a6df9197e108e310e90ca52f1d8b14b59fb368f59184aed3dc30abb9ca77417 WHIRLPOOL 6382ce336a5b4782b5300ce4838088d082529f58e43d9127b50b6357c61eb58b4e7da87f898d94bad90933b920c9a9ec02a1ad008f8786848aca69500cc24cad
DIST ppp-2.4.4.tar.gz 688763 SHA256 58af45fc07e5f326eea2408df770ea40e4626d1a15e7d564dd054d74880e91ea
DIST rp-pppoe-3.10.tar.gz 215288 SHA256 709ca7402594acc1d80b99c20219112b5c00e6ac48ae6049fc626fbaf4ce49f6
-EBUILD rp-pppoe-3.10-r1.ebuild 2586 SHA256 67ae3c50676be44808ff9b5fefa6b7a3a99c50133f204f35edaa60a1c7ecf677 WHIRLPOOL 0406ada54c76364af63891ca898d927ccffbf4e66ca296046b92d22b4a3a06b0c3b05987e955ff6ac0393ae5a45c5bd1e17db772f8905d6bc561e6d99b774082
+EBUILD rp-pppoe-3.10-r1.ebuild 2562 SHA256 2799f35a5a678b4194de2954e50c47badf28efab90bacfad075ae09a8ef1adfa WHIRLPOOL e0b756f4b012d0d524109c15e81c366fd7ab2c625e854a0bee9582b80473b82b703bbc518480f33a9ce8e60977d1119db0d0000de27b94c8fa826af7a9923dcf
MISC metadata.xml 139 SHA256 5cdc1888ebc8807b9a37b1d33429c61cabe7415a4f240e21a4c2ff8eca7a34ed WHIRLPOOL 620431014dd4fb752c3d46d11904ecb2c6d4525f5b4e30f4f778a3b74d3f7187ae4ccd856ebd7eabb48ce261b21849c732928fe647edce024a3fdc082d8f8630
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.10-r1.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.10-r1.ebuild
index 0e9f6b0a..226bbbfb 100644
--- a/net-dialup/rp-pppoe/rp-pppoe-3.10-r1.ebuild
+++ b/net-dialup/rp-pppoe/rp-pppoe-3.10-r1.ebuild
@@ -41,8 +41,6 @@ src_unpack() {
}
src_compile() {
- addpredict /dev/ppp
-
cd "${S}/src"
econf --enable-plugin=../../ppp-2.4.4 || die "econf failed"
emake || die "emake failed"
@@ -54,28 +52,26 @@ src_compile() {
src_install () {
cd "${S}/src"
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} install \
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install \
|| die "install failed"
#Don't use compiled rp-pppoe plugin - see pkg_preinst below
rm "${D}/etc/ppp/plugins/rp-pppoe.so"
- prepalldocs
-
if use X; then
- emake -C "${S}/gui" DESTDIR="${D}" datadir=/usr/share/doc/${PF}/ install \
+ emake -C "${S}/gui" DESTDIR="${D}" datadir="/usr/share/doc/${PF}/" install \
|| die "gui install failed"
- dosym /usr/share/doc/${PF}/tkpppoe /usr/share/tkpppoe
+ dosym "/usr/share/doc/${PF}/tkpppoe" /usr/share/tkpppoe
fi
}
pkg_preinst() {
# Use the rp-pppoe plugin that comes with net-dialup/pppd
local PPPD_VER=`best_version net-dialup/ppp`
- PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
- PPPD_VER=${PPPD_VER%%-*} #reduce it to ${PV}
+ PPPD_VER="${PPPD_VER#*/*-}" #reduce it to ${PV}-${PR}
+ PPPD_VER="${PPPD_VER%%-*}" #reduce it to ${PV}
if [ -n "${PPPD_VER}" ] && [ -f "${ROOT}/usr/lib/pppd/${PPPD_VER}/rp-pppoe.so" ] ; then
- dosym /usr/lib/pppd/${PPPD_VER}/rp-pppoe.so /etc/ppp/plugins/rp-pppoe.so
+ dosym "/usr/lib/pppd/${PPPD_VER}/rp-pppoe.so" /etc/ppp/plugins/rp-pppoe.so
fi
}