summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2005-03-10 21:45:08 +0000
committerBertrand Jacquin <beber@meleeweb.net>2005-03-10 21:45:08 +0000
commita9765f47ad900180107095245c467d2b21b8ca3c (patch)
tree8132d68d406c6646eb293d99a94ef73d1e85734e
parentDelete eclass because not necessary for now (diff)
downloadportage-a9765f47ad900180107095245c467d2b21b8ca3c.tar.xz
Add opencity
-rw-r--r--perso/games-strategy/opencity/ChangeLog16
-rw-r--r--perso/games-strategy/opencity/Manifest6
-rw-r--r--perso/games-strategy/opencity/files/digest-opencity-0.0.21
-rw-r--r--perso/games-strategy/opencity/files/digest-opencity-99990
-rw-r--r--perso/games-strategy/opencity/metadata.xml9
-rw-r--r--perso/games-strategy/opencity/opencity-0.0.2.ebuild42
-rw-r--r--perso/games-strategy/opencity/opencity-9999.ebuild50
7 files changed, 124 insertions, 0 deletions
diff --git a/perso/games-strategy/opencity/ChangeLog b/perso/games-strategy/opencity/ChangeLog
new file mode 100644
index 00000000..effd271e
--- /dev/null
+++ b/perso/games-strategy/opencity/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for games-strategy/opencity
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*koobyvolley-9999 (10 Mar 2005)
+
+ 10 Mar 2005; Bertrand Jacquin <beber.gentoo@gmail.com>
+ +opencity-9999.ebuild:
+ New ebuild for cvs. This work fine.
+
+*opencity-0.0.2 (10 Mar 2005)
+
+ 10 Mar 2005; Bertrand Jacquin <beber.gentoo@gmail.com>
+ +opencity-0.0.2.ebuild:
+ New Ebuild. Doesn't work because of path. You can compil but not use.
+ So masked
diff --git a/perso/games-strategy/opencity/Manifest b/perso/games-strategy/opencity/Manifest
new file mode 100644
index 00000000..dea93e32
--- /dev/null
+++ b/perso/games-strategy/opencity/Manifest
@@ -0,0 +1,6 @@
+MD5 344a684f72273489267cbdd02d8d22b6 opencity-9999.ebuild 1209
+MD5 77ad50275b22f7eca370bd3fe856ee79 ChangeLog 482
+MD5 a26b2af52a90ba476496df1f2b945e02 metadata.xml 252
+MD5 882142335e73a9253a120505171b61be opencity-0.0.2.ebuild 942
+MD5 d4747c3435d01aedba3d3909f3436ad1 files/digest-opencity-0.0.2 72
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-opencity-9999 0
diff --git a/perso/games-strategy/opencity/files/digest-opencity-0.0.2 b/perso/games-strategy/opencity/files/digest-opencity-0.0.2
new file mode 100644
index 00000000..dbeaae57
--- /dev/null
+++ b/perso/games-strategy/opencity/files/digest-opencity-0.0.2
@@ -0,0 +1 @@
+MD5 9f911256df82c0afd0ce62fefa670efe OpenCity-0.0.2stable.tar.gz 918514
diff --git a/perso/games-strategy/opencity/files/digest-opencity-9999 b/perso/games-strategy/opencity/files/digest-opencity-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/perso/games-strategy/opencity/files/digest-opencity-9999
diff --git a/perso/games-strategy/opencity/metadata.xml b/perso/games-strategy/opencity/metadata.xml
new file mode 100644
index 00000000..c6b49db3
--- /dev/null
+++ b/perso/games-strategy/opencity/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>beber.gentoo@gmail.com</email>
+ <name>Bertrand Jacquin</name>
+ <description/>
+</maintainer>
+</pkgmetadata>
diff --git a/perso/games-strategy/opencity/opencity-0.0.2.ebuild b/perso/games-strategy/opencity/opencity-0.0.2.ebuild
new file mode 100644
index 00000000..486535ed
--- /dev/null
+++ b/perso/games-strategy/opencity/opencity-0.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games
+
+DESCRIPTION="OpenCity is a 3D city simulator project based on OpenGL and SDL. It is not intended to be a clone of any famous city simulator from Max*s."
+HOMEPAGE="http://opencity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/OpenCity-0.0.2stable.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+RESTRICT="nomirror"
+
+S=${WORKDIR}/OpenCity-0.0.2stable
+
+src_compile()
+{
+ egamesconf || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ egamesinstall || die "egamesinstall failed"
+
+ dodir /usr/share/games/${PN}/font
+ insinto /usr/share/games/${PN}/font
+ doins ${S}/font/vera.ttf
+
+ dodoc AUTHORS ChangeLog NEWS README TODO docs/FAQ
+}
diff --git a/perso/games-strategy/opencity/opencity-9999.ebuild b/perso/games-strategy/opencity/opencity-9999.ebuild
new file mode 100644
index 00000000..ec122aca
--- /dev/null
+++ b/perso/games-strategy/opencity/opencity-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games cvs
+
+ECVS_SERVER="cvs.sf.net:/cvsroot/${PN}"
+ECVS_MODULE="developmentmodule"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/opencity"
+
+DESCRIPTION="OpenCity is a 3D city simulator project based on OpenGL and SDL. It is not intended to be a clone of any famous city simulator from Max*s."
+HOMEPAGE="http://opencity.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+src_compile()
+{
+ einfo "Running autogen.sh"
+ export WANT_AUTOMAKE=1.7
+ ./autogen.sh || die "autogen failed"
+
+ egamesconf --prefix=/usr/share/games/${PN} || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ egamesinstall prefix=${D}/usr/share/games/${PN} || die "egamesinstall failed"
+ for v in `find ${D} -type d -name CVS`; do
+ rm -r $v
+ done
+
+ dodir /usr/games/bin
+ mv ${D}/usr/share/games/${PN}/bin/* ${D}/usr/games/bin
+ rm -r ${D}/usr/share/games/${PN}/bin/
+
+ dodoc AUTHORS COPYRIGHT ChangeLog NEWS README TODO
+}