summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-12-18 16:00:39 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-12-18 16:00:39 +0000
commita50fbd24c7690e3f86c463a758e930f9ca7efe1c (patch)
treef7a691a77d25f3a5299b5b9c1ee0d0ef322e2d16
parentprofiles/enlightenment: Remove phabricator keywords (diff)
downloadportage-a50fbd24c7690e3f86c463a758e930f9ca7efe1c.tar.xz
www-apps/phabricator: Force TERM in webapp-config hook
Package-Manager: portage-2.3.0 RepoMan-Options: --force
-rw-r--r--www-apps/phabricator/Manifest2
-rwxr-xr-xwww-apps/phabricator/files/webapp-hook5
2 files changed, 5 insertions, 2 deletions
diff --git a/www-apps/phabricator/Manifest b/www-apps/phabricator/Manifest
index 883fcf54..db7c035c 100644
--- a/www-apps/phabricator/Manifest
+++ b/www-apps/phabricator/Manifest
@@ -7,7 +7,7 @@ AUX htaccess 475 SHA256 90b7245b7518f5b3e56bae9d574a530e3cd47808ef937bdc78ea4288
AUX phabricator.logrotate 56 SHA256 e63141278776888c1a3f8e841b0d263efe2beb6c9dbefa3d700fbd8912f4fe58 WHIRLPOOL 8fa63b4218f8757221cd4780e16c70d16e9849e6a89b9eecd327688bff9195bb1c0604c8e80e496cd659ef0a6fc9cfa79774a825d79be58c03e4f1a592ad07b9
AUX phd.confd 215 SHA256 80ddbf586f38cc600d06e524f7e85c3258bd563696fa2e41e1ea19268da8079b WHIRLPOOL 0f1a587c755994c410b62da6b897ca8684d584b9f01956359e078429fc7ec7642561dc3e3c306bbb24753e3a68ef5f088a5709706143b6154aa085ac2dfa52ad
AUX phd.initd 2435 SHA256 80bcf67fa7c8ada594113246abe19e1b420319ce976c0b2e90e20afcd67d688c WHIRLPOOL a1f8c061cc896703c4cc64c7273242b60eba865f4125c35700b82bad2d37a3c355957363d7d27411576bc304de5bf948b3c0d47702af26072fcbaedfd91c7fb1
-AUX webapp-hook 3544 SHA256 9d5858a801b13d3bb9b45a05eb2ba055e2967b03238aa8901262369de4cf8d65 WHIRLPOOL 6bfb35e7960015029f7fb9c73350aed34de483ae632fb0f6e08087cea65158c821cb3ef65bd1d367103b3939061ac39e8ad962e9d2152f0c635c14cb60560383
+AUX webapp-hook 3618 SHA256 31a07c3264ba0042885b8c429fa6fd338b61bcc0f49989f3950bd514619a98a8 WHIRLPOOL 92e7fb2ad4ffbb251fcb58cfc6f465f0d46bd5ce270e8ea10daf7c63d76ed7b852930d9da6eced5a5cecc7482e2d50a0b7ca9b69c2b282898e7369bfb4f7f5ff
EBUILD phabricator-20160709.ebuild 4818 SHA256 8a0420d8ace13fd8392a23bb644020b941192a5b080ee47cac1a667110df426a WHIRLPOOL 85f7e8f089ca4b583bdbca76b96a67ac793a6d16ca99b5becb1aec7f597a787b375822f2306f220e88db4c6c35e4034d285b66a3ca3d119470e64f23d3342e1c
EBUILD phabricator-20161213.ebuild 4818 SHA256 198d3113619e481702e295e14a96f6f43fa8e99a9da9cd0a54c33c49eb94c4be WHIRLPOOL ebd4401886ec1d2658409801c5eb958529c29421053d6135efc2d17978e80e27dae6fa9f1ea8e3e54b005a02102b314dd72919f3793ae5b38ebeb8021d4f9aed
EBUILD phabricator-9999.ebuild 4731 SHA256 85c9656a48d180fffd97a07f8b0ff423c34b6bdb2ea0c2b4f94d69a55b176d40 WHIRLPOOL 26ac98305e9c391f7faaf3e885571cdcb1d513d44dd8c625f2d8afd92c5343065d9dfd4120707bf11b9d34c548bc95a649bf82ef887d579ed7ea26a3a5718f3c
diff --git a/www-apps/phabricator/files/webapp-hook b/www-apps/phabricator/files/webapp-hook
index b5d9a3a5..ea7d9022 100755
--- a/www-apps/phabricator/files/webapp-hook
+++ b/www-apps/phabricator/files/webapp-hook
@@ -1,5 +1,5 @@
#!/bin/bash
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -82,6 +82,9 @@ function storage-upgrade () {
local _has_phd=no
local _has_server=no
+ # bin/storage uses tput but TERM get removed earlier
+ export TERM=vt100
+
# Do not upgrade anything if we can't connect to databases
if ! "${VHOST_ROOT}/bin/storage" databases > /dev/null ; then
ewarn "Aborting, connection to database unsuccessfull"