summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2008-08-09 18:31:36 +0200
committerBertrand Jacquin <beber@meleeweb.net>2008-08-09 18:31:36 +0200
commit9bfd3d5885125555934e11004699d3d4739b0cbf (patch)
tree0bc3fc755869a576bac81e5aa7f0fbf553cd7d9c
parentNew zenphoto release (diff)
downloadportage-9bfd3d5885125555934e11004699d3d4739b0cbf.tar.xz
New roundcube relase, and move it
-rw-r--r--mail-client/roundcube/Manifest (renamed from www-apps/roundcube/Manifest)2
-rw-r--r--mail-client/roundcube/files/postinstall-en.txt (renamed from www-apps/roundcube/files/postinstall-en.txt)0
-rw-r--r--mail-client/roundcube/files/roundcube-0.1-no-sockets-check.patch (renamed from www-apps/roundcube/files/roundcube-0.1-no-sockets-check.patch)0
-rw-r--r--mail-client/roundcube/roundcube-0.1.ebuild (renamed from www-apps/roundcube/roundcube-0.1.ebuild)0
-rw-r--r--mail-client/roundcube/roundcube-0.2_alpha.ebuild85
5 files changed, 87 insertions, 0 deletions
diff --git a/www-apps/roundcube/Manifest b/mail-client/roundcube/Manifest
index 67aede90..2f593bda 100644
--- a/www-apps/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,4 +1,6 @@
AUX postinstall-en.txt 2513 RMD160 c2a04efcdd4007642221797a10877c2fc57ad874 SHA1 8bc888b2944694bbbadeddfe6f193c3a8a995a87 SHA256 5c1fa9d43f29158521188aae417654f968fb41662c46721b8183728df37eb4c4
AUX roundcube-0.1-no-sockets-check.patch 2435 RMD160 1d03b74d38693edc6f816f2e34422d2b46442751 SHA1 62a5d11dc2bb437543eb449e4e6f4014a95c3ccf SHA256 3075384ee99ce0b5f0077b6a56e2a140afb00af6e12d6e32863ec14d03cd8696
DIST roundcubemail-0.1.tar.gz 1406854 RMD160 225b3a37c70bcf3b471b7d650233aec30dae2f76 SHA1 8b5b516b41bad98c3bbaf0da0e70b0db82580424 SHA256 ea4f4b23b9a20308cc0b1fef3b7301700c9ce4544189007bc62756e8d5f67051
+DIST roundcubemail-0.2-alpha.1.tar.gz 1378289 RMD160 b87768e5e11d474da9a8783c96b92354e47074a6 SHA1 af40c639d4815cc54b7287724925b807a52e8490 SHA256 abbfd96e4fdeb3183d842cb00c7c25abbff88ade98c4e352c125ea2ef008355a
EBUILD roundcube-0.1.ebuild 2754 RMD160 a3a6a933b79881d6eb0fbc8e6c4c78e9e3e63a13 SHA1 f63a4ddea99fd306eef8af6f1e0881f1d5edc5ed SHA256 87a066609833ec391a3cd461e24bb1fb803389108c2c7e06e123f61ef31a6c31
+EBUILD roundcube-0.2_alpha.ebuild 2748 RMD160 136fa4fa9e9b9a35d36853305b119996befd6b67 SHA1 a93b51624135c5e266b38412322f57c0a3798739 SHA256 91a04a631a49353d2979941ba59a83d74a73ea11f7427e9d742c9411afe473f7
diff --git a/www-apps/roundcube/files/postinstall-en.txt b/mail-client/roundcube/files/postinstall-en.txt
index d3d8138b..d3d8138b 100644
--- a/www-apps/roundcube/files/postinstall-en.txt
+++ b/mail-client/roundcube/files/postinstall-en.txt
diff --git a/www-apps/roundcube/files/roundcube-0.1-no-sockets-check.patch b/mail-client/roundcube/files/roundcube-0.1-no-sockets-check.patch
index 69bd5633..69bd5633 100644
--- a/www-apps/roundcube/files/roundcube-0.1-no-sockets-check.patch
+++ b/mail-client/roundcube/files/roundcube-0.1-no-sockets-check.patch
diff --git a/www-apps/roundcube/roundcube-0.1.ebuild b/mail-client/roundcube/roundcube-0.1.ebuild
index eed85f4c..eed85f4c 100644
--- a/www-apps/roundcube/roundcube-0.1.ebuild
+++ b/mail-client/roundcube/roundcube-0.1.ebuild
diff --git a/mail-client/roundcube/roundcube-0.2_alpha.ebuild b/mail-client/roundcube/roundcube-0.2_alpha.ebuild
new file mode 100644
index 00000000..816c2c76
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.2_alpha.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils webapp depend.php depend.apache
+
+MY_PN="${PN}mail"
+MY_PV="${PV/_/-}"
+MY_PV="${MY_PV/.1/}"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="A browser-based multilingual IMAP client using AJAX"
+HOMEPAGE="http://www.roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.1.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sqlite ssl spell"
+
+RDEPEND="dev-php/PEAR-PEAR"
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ local flags="crypt iconv imap pcre session unicode"
+ use ldap && flags="${flags} ldap"
+ use ssl && flags="${flags} ssl"
+ use spell && flags="${flags} curl ssl"
+
+ # check for required PHP features
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ local dbflags="mysql mysqli postgres sqlite"
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
+ die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
+ fi
+ else
+ for db in postgres sqlite ; do
+ use ${db} && flags="${flags} ${db}"
+ done
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
+ local diemsg="Re-install ${PHP_PKG} with ${flags}"
+ use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
+ die "${diemsg} in USE"
+ fi
+ fi
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+ use ldap || ewarn "PHP with USE=\"ldap\" is required for using LDAP addressbooks."
+ use ssl || ewarn "PHP with USE=\"ssl\" is required for IMAPS/STMPS functionality."
+ use spell || ewarn "PHP with USE=\"curl ssl\" required for spellchecker functionality."
+
+ webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv config/db.inc.php{.dist,}
+ mv config/main.inc.php{.dist,}
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ cp -R [[:lower:]]* SQL "${D}/${MY_HTDOCSDIR}"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}