summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2005-08-05 18:00:20 +0000
committerBertrand Jacquin <beber@meleeweb.net>2005-08-05 18:00:20 +0000
commit79365f4d1196c0577e484f5dab087d360465511d (patch)
tree8b1bb221b604d2cd969a8c4062e8bdf5d356e0bb
parentDel gentoofr dir (diff)
downloadportage-79365f4d1196c0577e484f5dab087d360465511d.tar.xz
Add efl-sharp
Doesn't work yet cause of VIOLATION
-rw-r--r--dev-dotnet/efl-sharp/Manifest2
-rw-r--r--dev-dotnet/efl-sharp/efl-sharp-9999.ebuild54
-rw-r--r--dev-dotnet/efl-sharp/files/digest-efl-sharp-99990
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-dotnet/efl-sharp/Manifest b/dev-dotnet/efl-sharp/Manifest
new file mode 100644
index 00000000..c51e1402
--- /dev/null
+++ b/dev-dotnet/efl-sharp/Manifest
@@ -0,0 +1,2 @@
+MD5 3b52dcbe76475229aa463f1994272de3 efl-sharp-9999.ebuild 1245
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-efl-sharp-9999 0
diff --git a/dev-dotnet/efl-sharp/efl-sharp-9999.ebuild b/dev-dotnet/efl-sharp/efl-sharp-9999.ebuild
new file mode 100644
index 00000000..bcf6ce99
--- /dev/null
+++ b/dev-dotnet/efl-sharp/efl-sharp-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+#
+
+inherit subversion eutils mono
+
+DESCRIPTION="EFL# is a .NET binding for the Enlightenment Foundation Libraries (EFL)."
+HOMEPAGE="http://efl-sharp.sourceforge.net/"
+
+ESVN_REPO_URI="svn://svn.myrealbox.com/source/trunk/efl-sharp/libs/efl-sharp"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="-*"
+
+RDEPEND="x11-libs/evas
+ x11-libs/ecore
+ media-libs/edje
+ x11-libs/ewl
+ media-libs/epsilon"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ subversion_svn_fetch
+ cd ${S}
+
+ # Use correct libdir in pkgconfig file
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ ${S}/efl-sharp.pc.in || die
+
+ aclocal || die "aclocal failed"
+ # See bug #73563, comment #9
+ libtoolize --copy --force || die "libtoolize --copy --force failed"
+ autoconf || die "autoconf failed"
+ automake --add-missing || die "automake --add-missing failed"
+
+ # disable building of samples (#16015)
+ sed -i -e "s:sample::" Makefile.in
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make GACUTIL_FLAGS="/root ${D}/usr/$(get_libdir) /gacdir /usr/$(get_libdir) /package ${PN}" \
+ DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS
+}
diff --git a/dev-dotnet/efl-sharp/files/digest-efl-sharp-9999 b/dev-dotnet/efl-sharp/files/digest-efl-sharp-9999
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/dev-dotnet/efl-sharp/files/digest-efl-sharp-9999