summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 18:28:00 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:19:07 +0100
commit73af7f34b799f63c726dd80897ccec5519937c9f (patch)
treef36c615f84116855adba42f75a74792edda433b3
parentdev-util/cpplint: move to EAPI 7 (diff)
downloadportage-73af7f34b799f63c726dd80897ccec5519937c9f.tar.xz
dev-php/libphutil: move to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1
-rw-r--r--dev-php/libphutil/libphutil-20190930.ebuild8
-rw-r--r--dev-php/libphutil/libphutil-9999.ebuild10
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-php/libphutil/libphutil-20190930.ebuild b/dev-php/libphutil/libphutil-20190930.ebuild
index dd952706..f2cbebe1 100644
--- a/dev-php/libphutil/libphutil-20190930.ebuild
+++ b/dev-php/libphutil/libphutil-20190930.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Collection of utility classes and functions for PHP used by phabricator"
@@ -25,6 +25,10 @@ DEPEND="!${CATEGORY}/${PN}:0
)"
RDEPEND="dev-lang/php[curl,iconv,json,mysql,mysqli,pcntl,ssl?,unicode]"
+PATCHES=(
+ "${FILESDIR}/${PV}-Remove-the-usage-of-local-SSL-certificates-and-use-s.patch"
+)
+
src_prepare() {
default
@@ -32,8 +36,6 @@ src_prepare() {
git remote add origin "${EGIT_REPO_URI}"
git remote -v > "${S}/GIT_REMOTE_INFO"
- eapply "${FILESDIR}/${PV}-Remove-the-usage-of-local-SSL-certificates-and-use-s.patch"
-
if use test ; then
tc-export AR CXX
fi
diff --git a/dev-php/libphutil/libphutil-9999.ebuild b/dev-php/libphutil/libphutil-9999.ebuild
index 372a3764..491cd686 100644
--- a/dev-php/libphutil/libphutil-9999.ebuild
+++ b/dev-php/libphutil/libphutil-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils toolchain-funcs git-r3
DESCRIPTION="Collection of utility classes and functions for PHP used by phabricator"
@@ -23,6 +23,10 @@ DEPEND="!${CATEGORY}/${PN}:stable
)"
RDEPEND="dev-lang/php[curl,iconv,json,mysql,mysqli,pcntl,ssl?,unicode]"
+PATCHES=(
+ "${FILESDIR}/${PV}-Remove-the-usage-of-local-SSL-certificates-and-use-s.patch"
+)
+
src_prepare() {
default
@@ -30,8 +34,6 @@ src_prepare() {
git remote add origin "${EGIT_REPO_URI}"
git remote -v > "${S}/GIT_REMOTE_INFO"
- eapply "${FILESDIR}/${PV}-Remove-the-usage-of-local-SSL-certificates-and-use-s.patch"
-
if use test ; then
tc-export AR CXX
fi