summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2017-10-15 22:59:49 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2018-01-15 21:40:08 +0000
commit533da49af4ce34e625e7e057e87242b854285dbd (patch)
treeb8f97b086eb2ced30c352f58af5df16c2903e887
parentdev-python/hidapi: Version bump (diff)
downloadportage-533da49af4ce34e625e7e057e87242b854285dbd.tar.xz
net-p2p/monero: Monero: the secure, private, untraceable cryptocurrency
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--net-p2p/monero/Manifest1
-rw-r--r--net-p2p/monero/files/0.11.0.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch34
-rw-r--r--net-p2p/monero/metadata.xml11
-rw-r--r--net-p2p/monero/monero-0.11.0.0.ebuild44
-rw-r--r--profiles/use.local.desc1
5 files changed, 91 insertions, 0 deletions
diff --git a/net-p2p/monero/Manifest b/net-p2p/monero/Manifest
new file mode 100644
index 00000000..07fb0ef8
--- /dev/null
+++ b/net-p2p/monero/Manifest
@@ -0,0 +1 @@
+DIST monero-0.11.0.0.tar.gz 55328701 SHA512 c5ac5b08e3ac027ae74c140f4a293dacb642a782a057cfc4ae5be2e2fdc5c669e6f647bc529f4f946345534e59f8d8e48e90c8c53d9871683f549335422488df WHIRLPOOL 835d617eb04683e6aa695e37c0bb0434393856a81dd9a0afab545b5b28761bc12cbf0c8fb6f14337375d58174fef4ccac2e81a7d5c6a53a686352ba146697f2d
diff --git a/net-p2p/monero/files/0.11.0.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch b/net-p2p/monero/files/0.11.0.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch
new file mode 100644
index 00000000..dd678276
--- /dev/null
+++ b/net-p2p/monero/files/0.11.0.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch
@@ -0,0 +1,34 @@
+From aa9c702eb7dcb529f91a972b05592797af154823 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sun, 15 Oct 2017 22:15:18 +0100
+Subject: [PATCH] blockchain_utilities: Add monero-blockchain-{ex,im}port
+ binaries to default install targets
+
+Binaries available to download on https://getmonero.org/downloads/ as
+embedding monerod, monero-wallet-{cli,rpc} and
+monero-blockchain-{ex,im}port.
+
+This change synchronise download results with a manual build from
+source
+---
+ src/blockchain_utilities/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/blockchain_utilities/CMakeLists.txt b/src/blockchain_utilities/CMakeLists.txt
+index 0eaf71084f56..bd32e0c552d0 100644
+--- a/src/blockchain_utilities/CMakeLists.txt
++++ b/src/blockchain_utilities/CMakeLists.txt
+@@ -93,6 +93,7 @@ endif()
+ set_property(TARGET blockchain_import
+ PROPERTY
+ OUTPUT_NAME "monero-blockchain-import")
++install(TARGETS blockchain_import DESTINATION bin)
+
+ monero_add_executable(blockchain_export
+ ${blockchain_export_sources}
+@@ -114,4 +115,5 @@ target_link_libraries(blockchain_export
+ set_property(TARGET blockchain_export
+ PROPERTY
+ OUTPUT_NAME "monero-blockchain-export")
++install(TARGETS blockchain_export DESTINATION bin)
+
diff --git a/net-p2p/monero/metadata.xml b/net-p2p/monero/metadata.xml
new file mode 100644
index 00000000..41f094a6
--- /dev/null
+++ b/net-p2p/monero/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <use>
+ <flag name="system-libs">Use system libraries instead of the ones included in the upstream distribution</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-p2p/monero/monero-0.11.0.0.ebuild b/net-p2p/monero/monero-0.11.0.0.ebuild
new file mode 100644
index 00000000..70c5e0dd
--- /dev/null
+++ b/net-p2p/monero/monero-0.11.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Monero: the secure, private, untraceable cryptocurrency"
+HOMEPAGE="https://getmonero.org"
+SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NEWLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc readline +system-libs unwind"
+
+RDEPEND="dev-db/lmdb
+ system-libs? (
+ net-dns/unbound
+ net-libs/miniupnpc )
+ dev-libs/openssl:0
+ dev-libs/boost:=
+ readline? ( sys-libs/readline:= )
+ net-libs/zeromq[sodium]
+ unwind? ( sys-libs/libunwind[lzma] )"
+DEPEND=">=dev-util/cmake-2.8.7
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen:0 )
+ ${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch" )
+
+src_configure () {
+ local mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DBUILD_DOCUMENTATION="$(usex doc ON OFF)"
+ -DBUILD_TESTS=OFF
+ -DCOVERAGE=OFF
+ -DUSE_READLINE="$(usex readline ON OFF)"
+ -DINSTALL_VENDORED_LIBUNBOUND="$(usex system-libs OFF ON)"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 9bbe640d..859ad3cc 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -64,6 +64,7 @@ media-video/rtmpdump:gnutls - Use GnuTLS library instead of the default OpenSSL
media-video/rtmpdump:polarssl - Use PolarSSL library instead of the default OpenSSL
net-misc/icmptx:client - Enable client support
net-misc/icmptx:server - Enable server support
+net-p2p/monero:system-libs - Use system libraries instead of the ones included in the upstream distribution
sys-firmware/gnuk:tools - Install aditional tools
virtual/linux-sources:firmware - Install linux kernel firmware
www-apps/phabricator:extension-sprint - Enable extension sprint via www-apps/phabricator-extensions-Sprint