summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-12-18 01:11:30 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-12-18 02:22:03 +0000
commit4f39e0c987ee608250e2905873eab3095d67e7e1 (patch)
tree565e4cea862f720391e6dd5d1deca759267b41f4
parentwww-apps/phabricator: Version bump (diff)
downloadportage-4f39e0c987ee608250e2905873eab3095d67e7e1.tar.xz
www-apps/phabricator-extensions-Sprint: Version bump
Package-Manager: portage-2.3.0
-rw-r--r--www-apps/phabricator-extensions-Sprint/Manifest5
-rw-r--r--www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20160709.ebuild2
-rw-r--r--www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20161003.ebuild84
-rw-r--r--www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild4
4 files changed, 90 insertions, 5 deletions
diff --git a/www-apps/phabricator-extensions-Sprint/Manifest b/www-apps/phabricator-extensions-Sprint/Manifest
index 2a93467d..248a3a63 100644
--- a/www-apps/phabricator-extensions-Sprint/Manifest
+++ b/www-apps/phabricator-extensions-Sprint/Manifest
@@ -1,3 +1,4 @@
-EBUILD phabricator-extensions-Sprint-20160709.ebuild 1951 SHA256 298a325736fca131819e69fccf61e2ae3c977e278bd4293ef05b22e1e8dad0ff WHIRLPOOL 649ed3391c1d7d423b06207b1469787604b732ab4365d58f2d124967875800d0d7ccbdd98e1de58e1cf8d82b456f7174ca5dae30e0d5a1e8100bdd1d8e8a40e9
-EBUILD phabricator-extensions-Sprint-9999.ebuild 1672 SHA256 6dea42848e2e404dcd6cd59325f4714f14e8ee0e8830efef77e2d46e1ebd9629 WHIRLPOOL 0778d0849240ff8c1a633a1f7d1c9dd150ee279b0ebd488948918aaa7e14ad6db014c21aee35d8df1eecb7be5df520eb967259fed41a22caa2a1216c7f3c5fac
+EBUILD phabricator-extensions-Sprint-20160709.ebuild 1950 SHA256 a7d355ffec8c4692b7859a5de904c33c6eb5d66cb8f59e1e48bdf3be55dd58b3 WHIRLPOOL 55b4b8eb7704fa9bfd4cf8e2244fad3799b4941fbc1ed890315cb4bd9df5c1a952acb34f63770ea6f13963911515e997b429d78e848f1ab9b695c692613d3aec
+EBUILD phabricator-extensions-Sprint-20161003.ebuild 1933 SHA256 62c1658981d32cd641fdb720dfa42a70f3b6cfaf328ae4ea0007144bce7021b0 WHIRLPOOL c1184aac153b6038d2b1195ebb0ad2d1a7e1b079ed4fd581abe52d3d655e3935f709725450d98731f4fdbb2961d555971f253158ea4d782e779e31fd30c1ac50
+EBUILD phabricator-extensions-Sprint-9999.ebuild 1655 SHA256 725edf17b217ee83a95e3f4e3ed8593d0391395c29c14d3217eb8e94e136d328 WHIRLPOOL afa790dcf2a7f053c4d8eec93801370891a7ce078b84e47e03965d1c7b35c225e3ac061cfad4711bbd70a7330f5d1fabb2582fba01a21b497f4e38f970ef85d4
MISC metadata.xml 270 SHA256 c04cdb11fb00afb6ff02df034d8b5b9f0e81547e40c6222532f7093720e11830 WHIRLPOOL 265753a2137d4b55b97549114cf475b9996e2358f570533f3db7ec7a91b7d3cfb60372ac9ebf83284ef963fc4c36f7e6fbeb144fba17a9cef6c402a74557cf94
diff --git a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20160709.ebuild b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20160709.ebuild
index ec633ba7..4b81caad 100644
--- a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20160709.ebuild
+++ b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20160709.ebuild
@@ -13,7 +13,7 @@ EGIT_COMMIT="release/2016-07-13/1"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="test"
DEPEND=""
diff --git a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20161003.ebuild b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20161003.ebuild
new file mode 100644
index 00000000..3c1a2b5b
--- /dev/null
+++ b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-20161003.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit git-r3
+
+DESCRIPTION="Manage your tasks with Points in Phabricator"
+HOMEPAGE="https://phabricator.wikimedia.org/diffusion/PHSP/"
+EGIT_REPO_URI="https://phabricator.wikimedia.org/diffusion/PHSP/phabricator-sprint.git"
+EGIT_BRANCH="wmf/stable"
+EGIT_COMMIT="release/2016-12-14/1"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="dev-php/libphutil
+ www-apps/phabricator"
+
+src_prepare() {
+ default
+
+ git log --format='%H %ct' -n 1 > "${S}/GIT_COMMIT_INFO"
+
+ find -type f -name .gitignore -print0 \
+ | xargs -0 --no-run-if-empty -- \
+ rm
+
+ # Replace 'env' shebang to files it point to
+ find -type f \
+ | sort \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!\/usr\/bin\/env/ {print FILENAME}' \
+ | while read ; do
+ set -- $(sed -ne '1 s:^#!\([^ ]*\) ::p;q' ${REPLY})
+ cmd="$1" ; shift ; args="$@"
+
+ case "${cmd}" in
+ bash|php) ;;
+ *) continue ;;
+ esac
+
+ path="$(type -p ${cmd})" || continue
+ [[ -z "${path}" ]] && continue
+
+ einfo "Changing ${REPLY} shebang to #!${path} ${args}"
+ sed -i \
+ -e "1 s:^#!.*:#!${path} ${args}:" \
+ "${REPLY}"
+ eend $?
+ done
+}
+
+src_test() {
+ arc unit --everything --no-coverage || die "arc unit failed"
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins GIT_COMMIT_INFO
+
+ insinto "/usr/share/php/${PN}"
+ doins -r rsrc scripts src
+
+ # Make executable all shebanged files
+ find "${ED}" -type f \
+ | xargs -n 1 --no-run-if-empty -- \
+ awk 'NR == 1 && /^#!/ {print FILENAME}' \
+ | sed -e "s:${ED}:/:" \
+ | xargs --no-run-if-empty -- \
+ fperms 755
+
+ dodoc README.md RELEASE_NOTES.md
+}
+
+pkg_postinst () {
+ elog
+ elog "After the first installation, you need to run:"
+ elog " cd /path/to/phabricator/install"
+ elog " bin/config set load-libraries '{\"sprint\":\"${EROOT}usr/share/php/${PN}/src\"}'"
+}
diff --git a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild
index af104e61..8ea90a7d 100644
--- a/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild
+++ b/www-apps/phabricator-extensions-Sprint/phabricator-extensions-Sprint-9999.ebuild
@@ -6,8 +6,8 @@ EAPI=6
inherit git-r3
DESCRIPTION="Manage your tasks with Points in Phabricator"
-HOMEPAGE="https://gerrit.wikimedia.org/r/#/admin/projects/phabricator/extensions/Sprint"
-EGIT_REPO_URI="https://gerrit.wikimedia.org/r/phabricator/extensions/Sprint"
+HOMEPAGE="https://phabricator.wikimedia.org/diffusion/PHSP/"
+EGIT_REPO_URI="https://phabricator.wikimedia.org/diffusion/PHSP/phabricator-sprint.git"
LICENSE="GPL-3"
SLOT="0"