summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2017-12-10 14:00:47 +0000
committerBertrand Jacquin <bertrand@jacquin.bzh>2018-03-07 01:30:06 +0000
commit481d1a3f8626be6d1c75271b5e282a2b211d7085 (patch)
tree4c4199e4f81f4996167c85f290ae819f27005009
parentnet-p2p/pesetacoin: Pesetacoin is a crypto-currency focused in the Spanish Co... (diff)
downloadportage-481d1a3f8626be6d1c75271b5e282a2b211d7085.tar.xz
net-p2p/monero: Version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--net-p2p/monero/Manifest2
-rw-r--r--net-p2p/monero/files/0.11.1.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch (renamed from net-p2p/monero/files/0.11.0.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch)0
-rw-r--r--net-p2p/monero/monero-0.11.1.0.ebuild (renamed from net-p2p/monero/monero-0.11.0.0.ebuild)20
3 files changed, 15 insertions, 7 deletions
diff --git a/net-p2p/monero/Manifest b/net-p2p/monero/Manifest
index 9608511e..f35c16c6 100644
--- a/net-p2p/monero/Manifest
+++ b/net-p2p/monero/Manifest
@@ -1 +1 @@
-DIST monero-0.11.0.0.tar.gz 55328701 BLAKE2B fcb9a2c976b2960a1fb2d43a872690c9bb8ea38be5810f43fa1176d79d235aa8af0be33d6cb0dd609e9aa48cc6e52debdd240b5220d855c0d3805c3eddf88b8b SHA512 c5ac5b08e3ac027ae74c140f4a293dacb642a782a057cfc4ae5be2e2fdc5c669e6f647bc529f4f946345534e59f8d8e48e90c8c53d9871683f549335422488df
+DIST monero-0.11.1.0.tar.gz 55329159 BLAKE2B ca543f6694a9117b12f6a0acf852943387d8c95215c9c70ea5a1e75595119715a255d9717cf76dfce00e88b5d01701949e352c4d1376b583de1e187b82664d1c SHA512 bac3520730164afe2ca992c588bd0b51791d986cd8d5ebcaac5bd48185b963e2391c28ee89399d7dd678a5d1f8b41c3ae5724d194a5f62bbcd3e6ad505986573
diff --git a/net-p2p/monero/files/0.11.0.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch b/net-p2p/monero/files/0.11.1.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch
index dd678276..dd678276 100644
--- a/net-p2p/monero/files/0.11.0.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch
+++ b/net-p2p/monero/files/0.11.1.0-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch
diff --git a/net-p2p/monero/monero-0.11.0.0.ebuild b/net-p2p/monero/monero-0.11.1.0.ebuild
index 70c5e0dd..a93f9acf 100644
--- a/net-p2p/monero/monero-0.11.0.0.ebuild
+++ b/net-p2p/monero/monero-0.11.1.0.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-utils
-DESCRIPTION="Monero: the secure, private, untraceable cryptocurrency"
+DESCRIPTION="Secure, private, untraceable cryptocurrency"
HOMEPAGE="https://getmonero.org"
SRC_URI="https://github.com/monero-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="NEWLIB"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc readline +system-libs unwind"
+KEYWORDS="~amd64"
+IUSE="doc qt5 readline +system-libs unwind"
RDEPEND="dev-db/lmdb
system-libs? (
net-dns/unbound
- net-libs/miniupnpc )
+ net-libs/miniupnpc
+ )
dev-libs/openssl:0
dev-libs/boost:=
readline? ( sys-libs/readline:= )
@@ -25,8 +26,10 @@ RDEPEND="dev-db/lmdb
DEPEND=">=dev-util/cmake-2.8.7
doc? (
media-gfx/graphviz
- app-doc/doxygen:0 )
+ app-doc/doxygen:0
+ )
${RDEPEND}"
+PDEPEND="qt5? ( =net-p2p/monero-gui-${PV} )"
PATCHES=( "${FILESDIR}/${PV}-blockchain_utilities-Add-monero-blockchain-ex-im-por.patch" )
@@ -38,7 +41,12 @@ src_configure () {
-DCOVERAGE=OFF
-DUSE_READLINE="$(usex readline ON OFF)"
-DINSTALL_VENDORED_LIBUNBOUND="$(usex system-libs OFF ON)"
+ -DBUILD_GUI_DEPS="$(usex qt5 ON OFF)"
)
+ export DATABASE="lmdb"
+ export DEVELOPER_LOCAL_TOOLS=0
+ export DEVELOPER_LIBUNBOUND_OLD=0
+
cmake-utils_src_configure
}