summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-01-03 03:18:43 +0000
committerBertrand Jacquin <beber@meleeweb.net>2006-01-03 03:18:43 +0000
commit448a03adc3355b7470c537624f3b6175653f1d4f (patch)
tree98801e02d74bb826f2e6f5190f42fbacafc6402f
parentadd files dir (diff)
downloadportage-448a03adc3355b7470c537624f3b6175653f1d4f.tar.xz
entrance enhancement
-rw-r--r--x11-misc/entrance/Manifest2
-rw-r--r--x11-misc/entrance/entrance-9999-r1.ebuild21
2 files changed, 12 insertions, 11 deletions
diff --git a/x11-misc/entrance/Manifest b/x11-misc/entrance/Manifest
index d5039f6b..99c438e1 100644
--- a/x11-misc/entrance/Manifest
+++ b/x11-misc/entrance/Manifest
@@ -1,5 +1,5 @@
MD5 308622652f1a12a9c4097ad2a2292d54 ChangeLog 1139
-MD5 84020572bdca7756ca9e15258efabd84 entrance-9999-r1.ebuild 2578
+MD5 cb07416250aa03991f1c8648a735aa11 entrance-9999-r1.ebuild 2508
MD5 8c2c9320269ef791ea0b6a00729a9104 files/digest-entrance-9999-r1 64
MD5 45c33488985394bc59f288720441f4f1 files/no-listen-tcp.patch 455
MD5 088d07394fa8372e79b7757075ea4a7d metadata.xml 515
diff --git a/x11-misc/entrance/entrance-9999-r1.ebuild b/x11-misc/entrance/entrance-9999-r1.ebuild
index c0a59366..bfd90b08 100644
--- a/x11-misc/entrance/entrance-9999-r1.ebuild
+++ b/x11-misc/entrance/entrance-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-9999.ebuild,v 1.3 2005/02/12 03:43:31 vapier Exp $
+# $
inherit enlightenment eutils
@@ -13,28 +13,29 @@ SRC_URI="${SRC_URI}
IUSE="pam listentcp"
-DEPEND="virtual/x11
+RDEPEND="|| ( x11-libs/libXau virtual/x11 )
pam? ( sys-libs/pam )
>=dev-db/edb-1.0.5
- >=x11-libs/evas-1.0.0_pre13
- >=x11-libs/ecore-1.0.0_pre7
+ >=x11-libs/evas-0.9.9
+ >=x11-libs/ecore-0.9.9
>=media-libs/edje-0.5.0
- >=x11-libs/esmart-0.0.2.20040501
- >=sys-apps/sed-4"
+ >=x11-libs/esmart-0.9.0"
+
+DEPEND="${RDEPEND}
+ || ( x11-libs/libXt virtual/x11 )"
src_unpack() {
enlightenment_src_unpack
if [ -d gentooed ] ; then
- mv gentooed ${S}/data/themes/
- cd ${S}/data/themes
+ mv gentooed "${S}"/data/themes/
+ cd "${S}"/data/themes
sed -i '/^SUBDIRS/s:$: gentooed:' Makefile.am
cp default/{Makefile.am,build_theme.sh} gentooed/
cd gentooed
ln -s images img
sed -i 's:default:gentooed:g' Makefile.am build_theme.sh
- sed -i 's:\(data/themes/default/Makefile\):\1 data/themes/gentooed/Makefile:' ${S}/configure.in
+ sed -i 's:\(data/themes/default/Makefile\):\1 data/themes/gentooed/Makefile:' "${S}"/configure.in
fi
- cd ${S}
if use listentcp; then
epatch ${FILESDIR}/no-listen-tcp.patch