summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2017-07-12 00:33:27 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2017-07-12 00:33:27 +0100
commit3d93aaf510d4fcb09b82aaa83515925ac710110f (patch)
treea6f4add70cc668d31261343eb8d0866f45597691
parentprofiles/enlightenment: Drop extra.enlightenment.org specific keywords (diff)
downloadportage-3d93aaf510d4fcb09b82aaa83515925ac710110f.tar.xz
dev-lang/php: Fix bad EPREFIX variable, drop kolab USE flag
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-lang/php/files/eblits/src_prepare-v2.eblit5
-rw-r--r--dev-lang/php/php-5.2.17.ebuild4
-rw-r--r--dev-lang/php/php-5.4.45.ebuild2
3 files changed, 3 insertions, 8 deletions
diff --git a/dev-lang/php/files/eblits/src_prepare-v2.eblit b/dev-lang/php/files/eblits/src_prepare-v2.eblit
index 02b1ffe4..4caaf525 100644
--- a/dev-lang/php/files/eblits/src_prepare-v2.eblit
+++ b/dev-lang/php/files/eblits/src_prepare-v2.eblit
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_prepare-v2.eblit,v 1.3 2011/01/05 11:23:16 mabi Exp $
@@ -11,9 +11,6 @@ eblit-php-src_prepare() {
addpredict /session_mm_cli250.sem
addpredict /session_mm_cli0.sem
- # kolab support (support for imap annotations)
- use kolab && epatch "${WORKDIR}/${PV}/opt/imap-kolab-annotations.patch"
-
# Change PHP branding
sed -re "s|^(PHP_EXTRA_VERSION=\").*(\")|\1${PHP_EXTRA_BRANDING}-pl${PR/r/}-gentoo\2|g" \
-i configure.in || die "Unable to change PHP branding"
diff --git a/dev-lang/php/php-5.2.17.ebuild b/dev-lang/php/php-5.2.17.ebuild
index 2ff79a7f..6fcd4645 100644
--- a/dev-lang/php/php-5.2.17.ebuild
+++ b/dev-lang/php/php-5.2.17.ebuild
@@ -78,7 +78,7 @@ LICENSE="PHP-3"
SAPIS="cli cgi embed apache2"
# Gentoo-specific, common features
-IUSE="kolab"
+IUSE=""
# SAPIs and SAPI-specific USE flags (cli SAPI is default on):
IUSE="${IUSE}
@@ -131,7 +131,6 @@ DEPEND=">=app-eselect/eselect-php-0.6.2
imap? ( virtual/imap-c-client[ssl=] )
iodbc? ( dev-db/libiodbc )
kerberos? ( virtual/krb5 )
- kolab? ( >=net-libs/c-client-2004g-r1 )
ldap? ( !oci8? ( >=net-nds/openldap-1.2.11 ) )
ldap-sasl? ( !oci8? ( dev-libs/cyrus-sasl >=net-nds/openldap-1.2.11 ) )
libedit? ( || ( sys-freebsd/freebsd-lib dev-libs/libedit ) )
@@ -201,7 +200,6 @@ RDEPEND="${DEPEND}
db2? ( $php[odbc] )
sapdb? ( $php[odbc] )
solid? ( $php[odbc] )
- kolab? ( $php[imap] )
oci8? ( $php[-oci8-instant-client,-ldap-sasl] )
oci8-instant-client? ( $php[-oci8] )
diff --git a/dev-lang/php/php-5.4.45.ebuild b/dev-lang/php/php-5.4.45.ebuild
index 901b207e..b4abbc33 100644
--- a/dev-lang/php/php-5.4.45.ebuild
+++ b/dev-lang/php/php-5.4.45.ebuild
@@ -524,7 +524,7 @@ src_configure() {
# we use the system copy of pcre
# --with-pcre-regex affects ext/pcre
# --with-pcre-dir affects ext/filter and ext/zip
- my_conf="${my_conf} --with-pcre-regex="{EPREFIX}"/usr --with-pcre-dir=${EPREFIX}/usr"
+ my_conf="${my_conf} --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
# Catch CFLAGS problems
# Fixes bug #14067.