summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <beber@meleeweb.net>2006-03-28 19:28:43 +0200
committerBertrand Jacquin <beber@meleeweb.net>2006-03-28 19:28:43 +0200
commit2f7c3eec25d300d9b6ac2360e47fb4f8c2434e4d (patch)
tree09d601290e086e10e07626f622c900d5dd46db6b
parentnew elitaire version (diff)
downloadportage-2f7c3eec25d300d9b6ac2360e47fb4f8c2434e4d.tar.xz
delete e.eclass while there is a new e cvs
new elitaire release
-rw-r--r--eclass/enlightenment.eclass168
-rw-r--r--games-board/elitaire/Manifest6
-rw-r--r--games-board/elitaire/elitaire-0.0.7.ebuild47
-rw-r--r--games-board/elitaire/files/digest-elitaire-0.0.73
4 files changed, 56 insertions, 168 deletions
diff --git a/eclass/enlightenment.eclass b/eclass/enlightenment.eclass
deleted file mode 100644
index 2fc8deee..00000000
--- a/eclass/enlightenment.eclass
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/enlightenment.eclass,v 1.61 2006/01/29 06:14:40 vapier Exp $
-#
-# Author: vapier@gentoo.org
-
-inherit eutils
-
-# ECVS_STATE's:
-# release [default]
-# KEYWORDS arch
-# SRC_URI $P.tar.gz
-# S $WORKDIR/$P
-#
-# snap $PV has .200##### datestamp or .### counter
-# KEYWORDS ~arch
-# SRC_URI $P.tar.bz2
-# S $WORKDIR/$P
-#
-# live $PV has a 9999 marker
-# KEYWORDS -*
-# SRC_URI `cvs up`
-# S $WORKDIR/$ECVS_MODULE
-#
-# Overrides:
-# KEYWORDS EKEY_STATE
-# SRC_URI EURI_STATE
-# S EURI_STATE
-
-EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postinst
-
-ECVS_STATE="release"
-if [[ ${PV/9999} != ${PV} ]] ; then
- if [[ -z ${ECVS_MODULE} ]] ; then
- ECVS_MODULE=${PN}
- if [[ ${CATEGORY/libs} != ${CATEGORY} ]] ; then
- ECVS_MODULE="e17/libs/${PN}"
- else
- ECVS_MODULE="e17/apps/${PN}"
- fi
- fi
- if [[ ! -z ${ECVS_MIRROR} ]]; then
- ECVS_STATE="mirror"
- else
- ECVS_SERVER=${E17_ECVS_SERVER:-${ECVS_SERVER:-cvs.sourceforge.net:/cvsroot/enlightenment}}
- ECVS_STATE="live"
- inherit cvs
- fi
-elif [[ ${PV/.200[3-9][0-1][0-9][0-3][0-9]/} != ${PV} ]] ; then
- ECVS_STATE="snap"
-elif [[ ${PV%%.[0-9][0-9][0-9]} != ${PV} ]] ; then
- ECVS_STATE="snap"
- EURI_STATE="release"
-fi
-
-DESCRIPTION="A DR17 production"
-HOMEPAGE="http://www.enlightenment.org/"
-case ${EURI_STATE:-${ECVS_STATE}} in
- release) SRC_URI="http://enlightenment.freedesktop.org/files/${P}.tar.gz mirror://sourceforge/enlightenment/${P}.tar.gz";;
- snap) SRC_URI="mirror://gentoo/${P}.tar.bz2";;
- mirror) SRC_URI="";;
- live) SRC_URI="";;
-esac
-
-LICENSE="BSD"
-SLOT="0"
-case ${EKEY_STATE:-${ECVS_STATE}} in
- release) KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86";;
- snap) KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86";;
- mirror) KEYWORDS="-*";;
- live) KEYWORDS="-*";;
-esac
-IUSE="nls doc"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND="nls? ( sys-devel/gettext )"
-
-case ${EURI_STATE:-${ECVS_STATE}} in
- release) S=${WORKDIR}/${P};;
- snap) S=${WORKDIR}/${PN};;
- mirror) S=${WORKDIR}/${PN};;
- live) S=${WORKDIR}/${ECVS_MODULE};;
-esac
-
-enlightenment_warning_msg() {
- if [[ ${ECVS_STATE} == "snap" ]] ; then
- ewarn "Please do not contact the E team about bugs in Gentoo."
- ewarn "Only contact vapier@gentoo.org via e-mail or bugzilla."
- ewarn "Remember, this stuff is CVS only code so dont cry when"
- ewarn "I break you :)."
- elif [[ ${ECVS_STATE} == "live" ]] ; then
- eerror "This is a LIVE CVS ebuild."
- eerror "That means there are NO promises it will work."
- eerror "If it fails to build, FIX THE CODE YOURSELF"
- eerror "before reporting any issues."
- fi
-}
-
-enlightenment_die() {
- enlightenment_warning_msg
- die "$@"$'\n'"!!! SEND BUG REPORTS TO vapier@gentoo.org NOT THE E TEAM"
-}
-
-enlightenment_pkg_setup() {
- enlightenment_warning_msg
-}
-
-# the stupid gettextize script prevents non-interactive mode, so we hax it
-gettext_modify() {
- use nls || return 0
- cp $(which gettextize) "${T}"/ || die "could not copy gettextize"
- sed -i \
- -e 's:read dummy < /dev/tty::' \
- "${T}"/gettextize
-}
-
-enlightenment_src_unpack() {
- if [[ ${ECVS_STATE} == "mirror" ]] ; then
- B="${PN}.tar.bz2"
- ln -sf /usr/portage/distfiles/${B} ${DISTDIR} 2> /dev/null
- wget -t 5 --passive-ftp ${ECVS_MIRROR}/${ECVS_MODULE}.tar.bz2 --progress=bar:force -N -P ${DISTDIR}
- unpack ${B}
- elif [[ ${ECVS_STATE} == "live" ]] ; then
- cvs_src_unpack
- else
- unpack ${A}
- fi
- gettext_modify
- [[ -s gendoc ]] && chmod a+rx gendoc
-}
-
-enlightenment_src_compile() {
- if [[ ! -e configure ]] ; then
- export WANT_AUTOMAKE=${EAUTOMAKE:-1.8}
- env \
- PATH="${T}:${PATH}" \
- NOCONFIGURE=yes \
- USER=blah \
- ./autogen.sh \
- || enlightenment_die "autogen failed"
- # symlinked files will cause sandbox violation
- for x in config.{guess,sub} ; do
- [[ ! -L ${x} ]] && continue
- rm -f ${x}
- touch ${x}
- done
- if [[ ! -z ${EHACKLIBLTDL} ]] ; then
- cd libltdl
- autoconf || enlightenment_die "autogen in libltdl failed"
- cd ..
- fi
- fi
- epunt_cxx
- econf ${MY_ECONF} || enlightenment_die "econf failed"
- emake || enlightenment_die "emake failed"
- use doc && [[ -x ./gendoc ]] && { ./gendoc || enlightenment_die "gendoc failed" ; }
-}
-
-enlightenment_src_install() {
- make install DESTDIR="${D}" || enlightenment_die
- find "${D}" -name CVS -type d -exec rm -rf '{}' \; 2>/dev/null
- dodoc AUTHORS ChangeLog NEWS README TODO ${EDOCS}
- use doc && [[ -d doc ]] && dohtml -r doc/*
-}
-
-enlightenment_pkg_postinst() {
- enlightenment_warning_msg
-}
diff --git a/games-board/elitaire/Manifest b/games-board/elitaire/Manifest
index 3459f84a..ecf10f30 100644
--- a/games-board/elitaire/Manifest
+++ b/games-board/elitaire/Manifest
@@ -7,6 +7,9 @@ SHA256 0ec3c5c939682a761a36151ec0ba309d4c798fa40ad445f447b69288efddc520 elitaire
MD5 2f927c0c750a120ae253fb3a56082831 elitaire-0.0.6.ebuild 776
RMD160 90b0c3d8a57263498e4a9367cde318df9f9def45 elitaire-0.0.6.ebuild 776
SHA256 0a7fdfd90f5adfe8624f864fcb59324eca1f1c5d0bd50e0d595517ef556be31f elitaire-0.0.6.ebuild 776
+MD5 6aaeaf6223a8eb7ed46f77dfce6f3a89 elitaire-0.0.7.ebuild 775
+RMD160 de4d6423bee4b06e75cd16502daf34c160b312cb elitaire-0.0.7.ebuild 775
+SHA256 ac2a8d908e595240e9b60c22352eddf478898ce41fdf2472bf5ba7a2af39062a elitaire-0.0.7.ebuild 775
MD5 7b3bdb611eae7c916f0bf009947bccbe files/digest-elitaire-0.0.2 244
RMD160 c6068409bb987fc4acf7b68672e4137ea09e4cdd files/digest-elitaire-0.0.2 244
SHA256 484c082ffc7ffe8d56ed3beea5bec686c8668b0400d6103a25e906fa89756d13 files/digest-elitaire-0.0.2 244
@@ -16,6 +19,9 @@ SHA256 8052aad575f7485dc821552cb0726df990d217eb9bff24578554d4df5ebfa3ab files/di
MD5 9477e7b38aac4fcf1dfa79e5de57e452 files/digest-elitaire-0.0.6 247
RMD160 4cb33927b70881c0a6d1f666cd2f301f035e9927 files/digest-elitaire-0.0.6 247
SHA256 ae0c91662928cdee6b698504d96a3e46300ada8fb47ed9e047baf8de0deba32e files/digest-elitaire-0.0.6 247
+MD5 5fd738cf34de8e1cfb7d1801528958ea files/digest-elitaire-0.0.7 244
+RMD160 dbee2c1666e0f92f547dde9947c27ab6a0c8f119 files/digest-elitaire-0.0.7 244
+SHA256 649deda281ee94ca5a6b52882e39b5ef8de39cd167d2c035dc0750805721e106 files/digest-elitaire-0.0.7 244
MD5 92723a7b33f3ab7cdd0bac2feb726cde files/elitaire-NULL-ABS.patch 952
RMD160 be7eeea1b06fb217c9830f7159a71b3a809ca1fb files/elitaire-NULL-ABS.patch 952
SHA256 afdea893a4a2ffc9e1bb9687c3677c103f8c4471721c923afe703c386c8b56e7 files/elitaire-NULL-ABS.patch 952
diff --git a/games-board/elitaire/elitaire-0.0.7.ebuild b/games-board/elitaire/elitaire-0.0.7.ebuild
new file mode 100644
index 00000000..f67c8c86
--- /dev/null
+++ b/games-board/elitaire/elitaire-0.0.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games
+
+DESCRIPTION="elitaire is an efl based solitaire card game"
+HOMEPAGE="http://www.mowem.de/elitaire/"
+SRC_URI="http://www.mowem.de/elitaire/${P}.tar.gz"
+
+LICENSE="AS-IS"
+SLOT="0"
+IUSE="nls"
+
+KEYWORDS="-*"
+
+DEPEND="nls? ( sys-devel/gettext )
+ dev-libs/eet
+ x11-libs/evas
+ media-libs/edje
+ x11-libs/ecore
+ x11-libs/esmart
+ x11-libs/ewl"
+RDEPEND=""
+
+RESTRICT="nomirror"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+# epatch ${FILESDIR}/elitaire-NULL-ABS.patch
+}
+
+src_compile()
+{
+ egamesconf \
+ $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ egamesinstall || die "einstall failed"
+
+ dodoc AUTHORS ChangeLog
+}
diff --git a/games-board/elitaire/files/digest-elitaire-0.0.7 b/games-board/elitaire/files/digest-elitaire-0.0.7
new file mode 100644
index 00000000..50d42b46
--- /dev/null
+++ b/games-board/elitaire/files/digest-elitaire-0.0.7
@@ -0,0 +1,3 @@
+MD5 11152365d405d31674f8a9b6439d1945 elitaire-0.0.7.tar.gz 534586
+RMD160 1b560c4fe607e207ccc47212412ba81176aa5ba3 elitaire-0.0.7.tar.gz 534586
+SHA256 353612aa8ed46fe3dc7e328e2234e2bddbbea2f59476a4ad94aeaa288458d659 elitaire-0.0.7.tar.gz 534586