summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-05-11 23:39:50 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2016-05-11 23:39:50 +0100
commit06e1211619a6bdbfa6cd0aa8cbab0b40feca7153 (patch)
treebb17cbdd2f71890dca6ed12959a45f0b70e2fdf8
parentsys-firmware/gnuk: Build regnual as well (diff)
downloadportage-06e1211619a6bdbfa6cd0aa8cbab0b40feca7153.tar.xz
sys-firmware/gnuk: Install tool/rsa_example.key
Package-Manager: portage-2.2.28
-rw-r--r--metadata/md5-cache/sys-firmware/gnuk-1.1.92
-rw-r--r--sys-firmware/gnuk/Manifest2
-rw-r--r--sys-firmware/gnuk/gnuk-1.1.9.ebuild7
3 files changed, 9 insertions, 2 deletions
diff --git a/metadata/md5-cache/sys-firmware/gnuk-1.1.9 b/metadata/md5-cache/sys-firmware/gnuk-1.1.9
index 2a9771ce..ed1ae379 100644
--- a/metadata/md5-cache/sys-firmware/gnuk-1.1.9
+++ b/metadata/md5-cache/sys-firmware/gnuk-1.1.9
@@ -9,4 +9,4 @@ LICENSE=GPL-3
RDEPEND=virtual/udev tools? ( python_targets_python2_7? ( >=dev-lang/python-2.7.5-r2:2.7 ) >=dev-lang/python-exec-2:=[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] dev-python/pyusb[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] dev-python/colorama[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] )
SLOT=0
_eclasses_=eutils 792f83d5ec9536cb5ccef375469d8bde git-r3 ef66dfc3db09f327af21cf32f140fb2b multibuild 742139c87a9fa3766f0c2b155e5522bf multilib d062ae4ba2fc40a19c11de2ad89b6616 python-r1 0f6937650a475d673baa5d0c8c0b37b3 python-utils-r1 2e6826f6a93ad2acf904eecf5b5fb6d2 toolchain-funcs d513d423d449877e49d99af3f7af7acb udev 73058269b3e70e34e084fa3981282338
-_md5_=c339e74cdf45ec703163c126c619dd3f
+_md5_=ba14559ba336ce3d8f07c27c5c7fbeb2
diff --git a/sys-firmware/gnuk/Manifest b/sys-firmware/gnuk/Manifest
index 32530215..528cf89d 100644
--- a/sys-firmware/gnuk/Manifest
+++ b/sys-firmware/gnuk/Manifest
@@ -1,4 +1,4 @@
AUX 10-stlink.rules 179 SHA256 8a89aff84d192d270234c9b58229025cdcfd3f5384f864a298d3cfb19b081ea4 WHIRLPOOL 2fba2148444183945f93cd6a0baaccf7e09c887eef245a52c5c17e92e653759e0e66f3a5bd7abae2099d9f2e1f944dd30631f2c1f21356a9424628f92607ab52
AUX 60-gnuk.rules 191 SHA256 faf65731989732c533426ffdce2be2a86f722a0b72ebb450fd2b45b93687986c WHIRLPOOL 0afd5dd7b7b0d6c488b89d65c92897c77490a3f9760b54b5c48716fb78a722b75723f52de3be9c2e3a50ec3df6e525bd92a56de3d6d455cc1b1eb3796a2b82eb
-EBUILD gnuk-1.1.9.ebuild 2832 SHA256 2dab2566d2054bc6c796e79e71f69b0773d57994aeb4afdec637596a8193579f WHIRLPOOL 5fa2668f662018cd97d251b1f29cbce4496c10795751f826932765dd25fb599287d59e6866de29975627f3b4163fd2174376a7616491c845d3bf31eb49bc2a12
+EBUILD gnuk-1.1.9.ebuild 2996 SHA256 3f5199a24d85a134700acf237bdd8c45b429df412f60605f8f4d66c86cb47cc4 WHIRLPOOL bafb41b7e11a4bfb93e570cc104e072d64f5c5ce546f58c717fb83f03b2d2917d83e72d9efdd58c7cff66315203779b48b20b46d84ae9756aa90ad3a9633ec41
MISC metadata.xml 335 SHA256 9e5ed8f755bc49eb8a0e96b55585a0b5b8f9ee74e1b2d9b71db438d1878dd306 WHIRLPOOL 4b1e0bb69b7ab34954eeb5efa451fcbcb39236eee31d33f2738b36b773d514fffcb3593a00b9993c1e4fdb90b0564bc87391ab3bf3c10c179437873badec4a39
diff --git a/sys-firmware/gnuk/gnuk-1.1.9.ebuild b/sys-firmware/gnuk/gnuk-1.1.9.ebuild
index 69d1bc9d..8702ddcd 100644
--- a/sys-firmware/gnuk/gnuk-1.1.9.ebuild
+++ b/sys-firmware/gnuk/gnuk-1.1.9.ebuild
@@ -83,6 +83,12 @@ src_install() {
doman doc/_build/man/*
fi
+ install_example() {
+ python_export PYTHON_SCRIPTDIR
+ insinto "${PYTHON_SCRIPTDIR}"
+ doins "${1}"
+ }
+
if use tools ; then
python_foreach_impl python_domodule tool/gnuk_token.py
python_foreach_impl python_domodule tool/gpg_agent.py
@@ -95,6 +101,7 @@ src_install() {
python_foreach_impl python_doscript "tool/${PN}-upgrade.py"
python_foreach_impl python_doscript "tool/${PN}-upgrade_by_passwd.py"
python_foreach_impl python_doscript "tool/${PN}-usb_strings.py"
+ python_foreach_impl install_example tool/rsa_example.key
udev_dorules "${FILESDIR}/10-stlink.rules"
fi