aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbeber <beber>2005-12-01 20:22:19 +0000
committerbeber <beber>2005-12-01 20:22:19 +0000
commit1d217fb1cf5b137fe0758015e90e4f38a5a0ba62 (patch)
treecf92fb109d6bc4cb81a66fa1d542efae34c1fc53 /configure.in
parentmore debug infos (diff)
downloadespik-1d217fb1cf5b137fe0758015e90e4f38a5a0ba62.tar.xz
Add a macro for __attribute__
Check if valgrinf is here Indent More debug and do better use config.h del ^_ from header
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a95c0de..83f8ce5 100644
--- a/configure.in
+++ b/configure.in
@@ -11,6 +11,7 @@ AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AM_PROG_CC_STDC
AC_HEADER_STDC
+AC_C___ATTRIBUTE__
AC_ARG_WITH(ecore-config,
[ --with-ecore-config=ECORE_CONFIG use ecore-config specified ],
@@ -26,6 +27,31 @@ ecore_libs=`$ECORE_CONFIG --libs`
AC_SUBST(ecore_cflags)
AC_SUBST(ecore_libs)
+# Setting have_valgrind to "no" seems pointless, but we just need to
+# put something in as the 4th parameter, so configure doesn't abort
+# when valgrind.pc isn't found.
+have_valgrind="no"
+PKG_CHECK_MODULES(VALGRIND, valgrind >= 2.4.0, have_valgrind=yes, have_valgrind=no)
+AC_ARG_ENABLE(valgrind,
+ [ --enable-valgrind enable valgrind support], [
+ if test x"$enableval" = x"yes" ; then
+ AC_MSG_RESULT(yes)
+ have_valgrind="yes"
+ else
+ AC_MSG_RESULT(no)
+ have_valgrind="no"
+ VALGRIND_CFLAGS=""
+ VALGRIND_LIBS=""
+ fi
+ ], [
+ have_valgrind=$have_valgrind
+ ]
+)
+
+if test x$have_valgrind = "xyes"; then
+ AC_DEFINE(HAVE_VALGRIND, 1, [Valgrind support])
+fi
+
AC_OUTPUT([
Makefile
src/Makefile])