aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 759bd71a..d7f4a418 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -42,8 +42,7 @@ check_PROGRAMS = \
test_bcj_exact_size \
test_memlimit \
test_lzip_decoder \
- test_vli \
- test_microlzma
+ test_vli
TESTS = \
test_check \
@@ -58,7 +57,6 @@ TESTS = \
test_memlimit \
test_lzip_decoder \
test_vli \
- test_microlzma \
test_files.sh \
test_suffix.sh \
test_compress_prepared_bcj_sparc \
@@ -67,6 +65,11 @@ TESTS = \
test_compress_generated_random \
test_compress_generated_text
+if COND_MICROLZMA
+check_PROGRAMS += test_microlzma
+TESTS += test_microlzma
+endif
+
if COND_SCRIPTS
TESTS += test_scripts.sh
endif