aboutsummaryrefslogtreecommitdiff
path: root/src/xz/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/xz/Makefile.am')
-rw-r--r--src/xz/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/xz/Makefile.am b/src/xz/Makefile.am
index a9b2f690..ba64d72b 100644
--- a/src/xz/Makefile.am
+++ b/src/xz/Makefile.am
@@ -30,12 +30,15 @@ xz_SOURCES = \
util.c \
util.h
+if COND_W32
+xz_SOURCES += xz_w32res.rc
+endif
+
xz_CPPFLAGS = \
-DLOCALEDIR=\"$(localedir)\" \
-I$(top_srcdir)/src/common \
-I$(top_srcdir)/src/liblzma/api \
-I$(top_builddir)/lib \
- -I$(top_srcdir)/lib \
$(STATIC_CPPFLAGS)
xz_LDFLAGS = $(STATIC_LDFLAGS)
@@ -49,6 +52,12 @@ endif
xz_LDADD += $(LTLIBINTL)
+# Windows resource compiler support
+.rc.o:
+ $(RC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(xz_CPPFLAGS) $(CPPFLAGS) $(RCFLAGS) -i $< -o $@
+
+
## Create symlinks for unxz and xzcat for convenience. Create symlinks also
## for lzma, unlzma, and lzcat for compatibility with LZMA Utils 4.32.x.
xzlinks = unxz xzcat lzma unlzma lzcat