aboutsummaryrefslogtreecommitdiff
path: root/src/xz/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/xz/Makefile.am')
-rw-r--r--src/xz/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/xz/Makefile.am b/src/xz/Makefile.am
index 8716752f..773654e9 100644
--- a/src/xz/Makefile.am
+++ b/src/xz/Makefile.am
@@ -58,6 +58,9 @@ xz_LDADD += $(LTLIBINTL)
$(xz_CPPFLAGS) $(CPPFLAGS) $(RCFLAGS) -i $< -o $@
+dist_man_MANS = xz.1
+
+
## Create symlinks for unxz and xzcat for convenience. Create symlinks also
## for lzma, unlzma, and lzcat for compatibility with LZMA Utils 4.32.x.
xzlinks = unxz xzcat lzma unlzma lzcat
@@ -70,6 +73,13 @@ install-exec-hook:
rm -f $$link && \
$(LN_S) $$target $$link; \
done
+ cd $(DESTDIR)$(mandir)/man1 && \
+ target=`echo xz | sed '$(transform)'` && \
+ for name in $(xzlinks); do \
+ link=`echo $$name | sed '$(transform)'` && \
+ rm -f $$link.1 && \
+ $(LN_S) $$target.1 $$link.1; \
+ done
uninstall-hook:
cd $(DESTDIR)$(bindir) && \
@@ -77,3 +87,8 @@ uninstall-hook:
link=`echo $$name | sed '$(transform)'` && \
rm -f $$link; \
done
+ cd $(DESTDIR)$(mandir)/man1 && \
+ for name in $(xzlinks); do \
+ link=`echo $$name | sed '$(transform)'` && \
+ rm -f $$link.1; \
+ done