aboutsummaryrefslogtreecommitdiff
path: root/src/xz/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/xz/Makefile.am')
-rw-r--r--src/xz/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/xz/Makefile.am b/src/xz/Makefile.am
index 5deed299..02dd8357 100644
--- a/src/xz/Makefile.am
+++ b/src/xz/Makefile.am
@@ -42,12 +42,10 @@ xz_CPPFLAGS = \
-I@top_srcdir@/src/common \
-I@top_srcdir@/src/liblzma/api \
-I@top_builddir@/lib \
- -I@top_srcdir@/lib
+ -I@top_srcdir@/lib \
+ @STATIC_CPPFLAGS@
-## Always link the command line tool statically against liblzma. It is
-## faster on x86, because no need for PIC. We also have one dependency less,
-## which allows users to more freely copy the xz binary to other boxes.
-xz_LDFLAGS = -static
+xz_LDFLAGS = @STATIC_LDFLAGS@
xz_LDADD = \
@top_builddir@/src/liblzma/liblzma.la \
@LTLIBINTL@