aboutsummaryrefslogtreecommitdiff
path: root/src/liblzma/simple/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/liblzma/simple/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/liblzma/simple/Makefile.am b/src/liblzma/simple/Makefile.am
index a37f1eb5..f8cd4888 100644
--- a/src/liblzma/simple/Makefile.am
+++ b/src/liblzma/simple/Makefile.am
@@ -21,6 +21,18 @@ libsimple_la_SOURCES = \
simple_coder.h \
simple_private.h
+if COND_ENCODER_SIMPLE
+libsimple_la_SOURCES += \
+ simple_encoder.c \
+ simple_encoder.h
+endif
+
+if COND_DECODER_SIMPLE
+libsimple_la_SOURCES += \
+ simple_decoder.c \
+ simple_decoder.h
+endif
+
if COND_FILTER_X86
libsimple_la_SOURCES += x86.c
endif