aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f03f5a3d..9fb4caad 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,5 +5,18 @@
## You can do whatever you want with this file.
##
-SUBDIRS = liblzma xz xzdec lzmainfo scripts
+SUBDIRS = liblzma xzdec
+
+if COND_XZ
+SUBDIRS += xz
+endif
+
+if COND_LZMAINFO
+SUBDIRS += lzmainfo
+endif
+
+if COND_SCRIPTS
+SUBDIRS += scripts
+endif
+
EXTRA_DIST = common