aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 37949a94..25eb838f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -457,7 +457,11 @@ if test "x$enable_threads" = xyes; then
AX_PTHREAD
LIBS="$LIBS $PTHREAD_LIBS"
AM_CFLAGS="$AM_CFLAGS $PTHREAD_CFLAGS"
- CC="$PTHREAD_CC"
+
+ dnl NOTE: PTHREAD_CC is ignored. It would be useful on AIX, but
+ dnl it's tricky to get it right together with AC_PROG_CC_C99.
+ dnl Thus, this is handled by telling the user in INSTALL to set
+ dnl the correct CC manually.
# These are nice to have but not mandatory.
OLD_CFLAGS=$CFLAGS