aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 22 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7443489a..57f60f69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -493,7 +493,28 @@ if test "x$enable_symbol_versions" = xauto; then
esac
fi
AC_MSG_RESULT([$enable_symbol_versions])
-AM_CONDITIONAL([COND_SYMVERS], [test "x$enable_symbol_versions" = xyes])
+
+# There are two variants for symbol versioning.
+# See src/liblzma/validate_map.sh for details.
+if test "x$enable_symbol_versions" = xyes; then
+ case $host_os in
+ linux*)
+ enable_symbol_versions=linux
+ AC_DEFINE([HAVE_SYMBOL_VERSIONS_LINUX], [1],
+ [Define to 1 to if GNU/Linux-specific details
+ are wanted for symbol versioning. This must
+ be used together with liblzma_linux.map.])
+ ;;
+ *)
+ enable_symbol_versions=generic
+ ;;
+ esac
+fi
+
+AM_CONDITIONAL([COND_SYMVERS_LINUX],
+ [test "x$enable_symbol_versions" = xlinux])
+AM_CONDITIONAL([COND_SYMVERS_GENERIC],
+ [test "x$enable_symbol_versions" = xgeneric])
##############