aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6bdc47d..9304da31 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -390,9 +390,11 @@ if(ENABLE_THREADS)
target_link_libraries(liblzma Threads::Threads)
add_compile_definitions(MYTHREAD_POSIX)
- # Check if pthread_condattr_setclock() exists to use CLOCK_MONOTONIC.
+ # Check if pthread_condattr_setclock() exists to
+ # use CLOCK_MONOTONIC.
if(HAVE_CLOCK_MONOTONIC)
- list(INSERT CMAKE_REQUIRED_LIBRARIES 0 "${CMAKE_THREAD_LIBS_INIT}")
+ list(INSERT CMAKE_REQUIRED_LIBRARIES 0
+ "${CMAKE_THREAD_LIBS_INIT}")
check_symbol_exists(pthread_condattr_setclock pthread.h
HAVE_PTHREAD_CONDATTR_SETCLOCK)
tuklib_add_definition_if(ALL HAVE_PTHREAD_CONDATTR_SETCLOCK)