aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2022-06-10 21:35:18 +0800
committerLasse Collin <lasse.collin@tukaani.org>2022-06-10 16:58:47 +0300
commitaa75c5563a760aea3aa23d997d519e702e82726b (patch)
tree6c1219bf5d268cb1be4744a868ae9cfc20035d8d /tests/Makefile.am
parentTests: Convert test_check to tuktest. (diff)
downloadxz-aa75c5563a760aea3aa23d997d519e702e82726b.tar.xz
Tests: Created tests for hardware functions.
Created tests for all API functions exported in src/liblzma/api/lzma/hardware.h. The tests are fairly trivial but are helpful because they will inform users if their machines cannot support these functions. They also improve the code coverage metrics.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e049add4..ae63f464 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -39,6 +39,7 @@ LDADD += $(LTLIBINTL)
check_PROGRAMS = \
create_compress_files \
test_check \
+ test_hardware \
test_stream_flags \
test_filter_flags \
test_block_header \
@@ -47,6 +48,7 @@ check_PROGRAMS = \
TESTS = \
test_check \
+ test_hardware \
test_stream_flags \
test_filter_flags \
test_block_header \