aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2022-06-12 11:31:40 +0800
committerLasse Collin <lasse.collin@tukaani.org>2022-06-14 22:00:34 +0300
commita08f5ccf6bdc20ef70e41f6f3321618ef146f96e (patch)
tree5f92af12e3cada8602bd4c3c828d58617376cf26 /tests/Makefile.am
parentAdded parallel test artifacts to .gitignore (diff)
downloadxz-a08f5ccf6bdc20ef70e41f6f3321618ef146f96e.tar.xz
Created tests for all functions exported in vli.h
Achieved 100% code coverage vli_encoder.c, vli_decoder.c, and vli_size.c
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ae63f464..ebf2df92 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -44,7 +44,8 @@ check_PROGRAMS = \
test_filter_flags \
test_block_header \
test_index \
- test_bcj_exact_size
+ test_bcj_exact_size \
+ test_vli
TESTS = \
test_check \
@@ -54,6 +55,7 @@ TESTS = \
test_block_header \
test_index \
test_bcj_exact_size \
+ test_vli \
test_files.sh \
test_compress_prepared_bcj_sparc \
test_compress_prepared_bcj_x86 \