aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2023-11-17 20:35:11 +0800
committerJia Tan <jiat0218@gmail.com>2023-12-22 20:02:06 +0800
commitafcb30fcadae4d07ec08d5f44eabc1905b2392b1 (patch)
tree139291c2d6fa245da059f88a772e2c011d60ccc6 /tests/Makefile.am
parentxz: Fix suffix check. (diff)
downloadxz-afcb30fcadae4d07ec08d5f44eabc1905b2392b1.tar.xz
Tests: Create test_suffix.sh.
This tests some complicated interactions with the --suffix= option. The suffix option must be used with --format=raw, but can optionally be used to override the default .xz suffix. This test also verifies some recent bugs have been correctly solved and to hopefully avoid further regressions in the future.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ebc33a7b..8a0ec53e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,6 +18,7 @@ EXTRA_DIST = \
test_compress_generated_random \
test_compress_generated_text \
test_scripts.sh \
+ test_suffix.sh \
bcj_test.c \
compress_prepared_bcj_sparc \
compress_prepared_bcj_x86 \
@@ -61,6 +62,7 @@ TESTS = \
test_lzip_decoder \
test_vli \
test_files.sh \
+ test_suffix.sh \
test_compress_prepared_bcj_sparc \
test_compress_prepared_bcj_x86 \
test_compress_generated_abc \