aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJia Tan <jiat0218@gmail.com>2022-12-29 00:25:18 +0800
committerJia Tan <jiat0218@gmail.com>2023-01-02 22:20:04 +0800
commit3959162baec074511d83ba0fec1284c3ed724799 (patch)
tree5360ec5c8c7bb7a7474064cbd0077ec9600e83d3 /tests/Makefile.am
parentliblzma: Add NULL check to lzma_index_hash_append. (diff)
downloadxz-3959162baec074511d83ba0fec1284c3ed724799.tar.xz
Tests: Creates test_index_hash.c
Tests all API functions exported from index_hash.h. Does not have a dedicated test for lzma_index_hash_end.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f84c1749..b1a2378a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -26,6 +26,7 @@ EXTRA_DIST = \
AM_CPPFLAGS = \
-I$(top_srcdir)/src/common \
-I$(top_srcdir)/src/liblzma/api \
+ -I$(top_srcdir)/src/liblzma \
-I$(top_builddir)/lib
LDADD = $(top_builddir)/src/liblzma/liblzma.la
@@ -44,6 +45,7 @@ check_PROGRAMS = \
test_filter_flags \
test_block_header \
test_index \
+ test_index_hash \
test_bcj_exact_size \
test_memlimit \
test_lzip_decoder \
@@ -56,6 +58,7 @@ TESTS = \
test_filter_flags \
test_block_header \
test_index \
+ test_index_hash \
test_bcj_exact_size \
test_memlimit \
test_lzip_decoder \