aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2022-05-23 21:17:47 +0300
committerLasse Collin <lasse.collin@tukaani.org>2022-05-23 21:31:20 +0300
commit9a6dd6d46f7f256a5573e5d874c1052033ed7b05 (patch)
tree87e5f43d35f693b8930e1da5d359af8d0b96fd73 /tests/Makefile.am
parentTest: Make create_compress_files.c a little more flexible. (diff)
downloadxz-9a6dd6d46f7f256a5573e5d874c1052033ed7b05.tar.xz
Tests: Split test_compress.sh into separate test unit for each file.
test_compress.sh now takes one command line argument: a filename to be tested. If it begins with "compress_generated_" the file will be created with create_compress_files. This will allow parallel execution of the slow tests.
Diffstat (limited to '')
-rw-r--r--tests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4116b81a..f576ac12 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -11,6 +11,11 @@ EXTRA_DIST = \
tests.h \
test_files.sh \
test_compress.sh \
+ test_compress_prepared_bcj_sparc \
+ test_compress_prepared_bcj_x86 \
+ test_compress_generated_abc \
+ test_compress_generated_random \
+ test_compress_generated_text \
test_scripts.sh \
bcj_test.c \
compress_prepared_bcj_sparc \
@@ -47,7 +52,11 @@ TESTS = \
test_index \
test_bcj_exact_size \
test_files.sh \
- test_compress.sh
+ test_compress_prepared_bcj_sparc \
+ test_compress_prepared_bcj_x86 \
+ test_compress_generated_abc \
+ test_compress_generated_random \
+ test_compress_generated_text
if COND_SCRIPTS
TESTS += test_scripts.sh