aboutsummaryrefslogtreecommitdiff
path: root/src/xzdec/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-11-15 12:40:17 +0200
committerLasse Collin <lasse.collin@tukaani.org>2009-11-15 12:40:17 +0200
commit93e418562cf127a9171e87bcd4e9af8e1bfcdae4 (patch)
treeed57e18edfa1758f3763d7b85c370a8926861ccb /src/xzdec/Makefile.am
parentUpdated THANKS. (diff)
downloadxz-93e418562cf127a9171e87bcd4e9af8e1bfcdae4.tar.xz
Add lzma_physmem().
I had hoped to keep liblzma as purely a compression library as possible (e.g. file I/O will go into a different library), but it seems that applications linking agaisnt liblzma need some way to determine the memory usage limit, and knowing the amount of RAM is one reasonable way to help making such decisions. Thanks to Jonathan Nieder for the original patch.
Diffstat (limited to 'src/xzdec/Makefile.am')
-rw-r--r--src/xzdec/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/xzdec/Makefile.am b/src/xzdec/Makefile.am
index 9a1b4342..ad487721 100644
--- a/src/xzdec/Makefile.am
+++ b/src/xzdec/Makefile.am
@@ -17,8 +17,7 @@ bin_PROGRAMS = xzdec lzmadec
xzdec_SOURCES = \
xzdec.c \
$(top_srcdir)/src/common/tuklib_progname.c \
- $(top_srcdir)/src/common/tuklib_exit.c \
- $(top_srcdir)/src/common/tuklib_physmem.c
+ $(top_srcdir)/src/common/tuklib_exit.c
if COND_W32
xzdec_SOURCES += xzdec_w32res.rc
@@ -43,8 +42,7 @@ xzdec_LDADD += $(LTLIBINTL)
lzmadec_SOURCES = \
xzdec.c \
$(top_srcdir)/src/common/tuklib_progname.c \
- $(top_srcdir)/src/common/tuklib_exit.c \
- $(top_srcdir)/src/common/tuklib_physmem.c
+ $(top_srcdir)/src/common/tuklib_exit.c
if COND_W32
lzmadec_SOURCES += lzmadec_w32res.rc