aboutsummaryrefslogtreecommitdiff
path: root/src/xzdec/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-11-19 23:52:24 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-11-19 23:52:24 +0200
commit1880a3927b23f265f63b2adb86fbdb81ea09eb06 (patch)
tree2fe1b65d21f81b28f46eb707378d97f553e99ee1 /src/xzdec/Makefile.am
parentOh well, big messy commit again. Some highlights: (diff)
downloadxz-1880a3927b23f265f63b2adb86fbdb81ea09eb06.tar.xz
Renamed lzma to xz and lzmadec to xzdec. We create symlinks
lzma, unlzma, and lzcat in "make install" for backwards compatibility with LZMA Utils 4.32.x; I'm not sure if this should be the default though.
Diffstat (limited to '')
-rw-r--r--src/xzdec/Makefile.am (renamed from src/lzmadec/Makefile.am)12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/lzmadec/Makefile.am b/src/xzdec/Makefile.am
index 650eb1c4..8c8cae80 100644
--- a/src/lzmadec/Makefile.am
+++ b/src/xzdec/Makefile.am
@@ -12,18 +12,18 @@
## Lesser General Public License for more details.
##
-bin_PROGRAMS = lzmadec
+bin_PROGRAMS = xzdec
-lzmadec_SOURCES = lzmadec.c
-lzmadec_CPPFLAGS = \
+xzdec_SOURCES = xzdec.c
+xzdec_CPPFLAGS = \
-I@top_srcdir@/src/common \
-I@top_srcdir@/src/liblzma/api \
-I@top_builddir@/lib
-lzmadec_LDFLAGS = -static
-lzmadec_LDADD = \
+xzdec_LDFLAGS = -static
+xzdec_LDADD = \
@top_builddir@/src/liblzma/liblzma.la \
@LTLIBINTL@
if COND_GNULIB
-lzmadec_LDADD += @top_builddir@/lib/libgnu.a
+xzdec_LDADD += @top_builddir@/lib/libgnu.a
endif