aboutsummaryrefslogtreecommitdiff
path: root/src/xz/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2015-11-03 20:29:33 +0200
committerLasse Collin <lasse.collin@tukaani.org>2015-11-03 20:29:33 +0200
commitcb3111e3ed84152912b5138d690c8d9f00c6ef02 (patch)
treea706e5bcb842a342b8e3290e5b961e15467ee3c8 /src/xz/Makefile.am
parentBuild: Build LZMA1/2 presets also when only decoder is wanted. (diff)
downloadxz-cb3111e3ed84152912b5138d690c8d9f00c6ef02.tar.xz
xz: Make xz buildable even when encoders or decoders are disabled.
The patch is quite long but it's mostly about adding new #ifdefs to omit code when encoders or decoders have been disabled. This adds two new #defines to config.h: HAVE_ENCODERS and HAVE_DECODERS.
Diffstat (limited to 'src/xz/Makefile.am')
-rw-r--r--src/xz/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/xz/Makefile.am b/src/xz/Makefile.am
index 500be411..2c6e6f54 100644
--- a/src/xz/Makefile.am
+++ b/src/xz/Makefile.am
@@ -16,8 +16,6 @@ xz_SOURCES = \
file_io.h \
hardware.c \
hardware.h \
- list.c \
- list.h \
main.c \
main.h \
message.c \
@@ -39,6 +37,12 @@ xz_SOURCES = \
../common/tuklib_mbstr_width.c \
../common/tuklib_mbstr_fw.c
+if COND_MAIN_DECODER
+xz_SOURCES = \
+ list.c \
+ list.h
+endif
+
if COND_W32
xz_SOURCES += xz_w32res.rc
endif