aboutsummaryrefslogtreecommitdiff
path: root/src/xz/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2015-03-31 22:19:34 +0300
committerLasse Collin <lasse.collin@tukaani.org>2016-12-26 20:40:27 +0200
commitce2542d220de06acd618fd9f5c0a6683029fb4eb (patch)
treec9ec0bbdb4ea8c18ac4b79803f994a7573b9d72d /src/xz/Makefile.am
parentFix bugs and otherwise improve ax_check_capsicum.m4. (diff)
downloadxz-ce2542d220de06acd618fd9f5c0a6683029fb4eb.tar.xz
xz: Add support for sandboxing with Capsicum (disabled by default).
In the v5.2 branch this feature is considered experimental and thus disabled by default. The sandboxing is used conditionally as described in main.c. This isn't optimal but it was much easier to implement than a full sandboxing solution and it still covers the most common use cases where xz is writing to standard output. This should have practically no effect on performance even with small files as fork() isn't needed. C and locale libraries can open files as needed. This has been fine in the past, but it's a problem with things like Capsicum. io_sandbox_enter() tries to ensure that various locale-related files have been loaded before cap_enter() is called, but it's possible that there are other similar problems which haven't been seen yet. Currently Capsicum is available on FreeBSD 10 and later and there is a port to Linux too. Thanks to Loganaden Velvindron for help.
Diffstat (limited to 'src/xz/Makefile.am')
-rw-r--r--src/xz/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/xz/Makefile.am b/src/xz/Makefile.am
index 2b6acf12..0890aad7 100644
--- a/src/xz/Makefile.am
+++ b/src/xz/Makefile.am
@@ -53,7 +53,7 @@ xz_CPPFLAGS = \
-I$(top_srcdir)/src/liblzma/api \
-I$(top_builddir)/lib
-xz_LDADD = $(top_builddir)/src/liblzma/liblzma.la
+xz_LDADD = $(top_builddir)/src/liblzma/liblzma.la $(CAPSICUM_LIB)
if COND_GNULIB
xz_LDADD += $(top_builddir)/lib/libgnu.a