aboutsummaryrefslogtreecommitdiff
path: root/src/xz/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-06-26 14:47:31 +0300
committerLasse Collin <lasse.collin@tukaani.org>2009-06-26 14:47:31 +0300
commit1c9360b7d1197457aaad2f8888b99f1149861579 (patch)
tree9b5cec00c4dd3c08d2b9c12134d3c3293af4eb9b /src/xz/Makefile.am
parentAllow to explicitly specify autotool versions in autogen.sh. (diff)
downloadxz-1c9360b7d1197457aaad2f8888b99f1149861579.tar.xz
Fix @variables@ to $(variables) in Makefile.am files.
Fix the ordering of libgnu.a and LTLIBINTL on the linker command line and added missing LTLIBINTL to tests/Makefile.am.
Diffstat (limited to 'src/xz/Makefile.am')
-rw-r--r--src/xz/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/src/xz/Makefile.am b/src/xz/Makefile.am
index 63d58728..ff88a839 100644
--- a/src/xz/Makefile.am
+++ b/src/xz/Makefile.am
@@ -32,21 +32,22 @@ xz_SOURCES = \
xz_CPPFLAGS = \
-DLOCALEDIR=\"$(localedir)\" \
- -I@top_srcdir@/src/common \
- -I@top_srcdir@/src/liblzma/api \
- -I@top_builddir@/lib \
- -I@top_srcdir@/lib \
- @STATIC_CPPFLAGS@
+ -I$(top_srcdir)/src/common \
+ -I$(top_srcdir)/src/liblzma/api \
+ -I$(top_builddir)/lib \
+ -I$(top_srcdir)/lib \
+ $(STATIC_CPPFLAGS)
-xz_LDFLAGS = @STATIC_LDFLAGS@
-xz_LDADD = \
- @top_builddir@/src/liblzma/liblzma.la \
- @LTLIBINTL@
+xz_LDFLAGS = $(STATIC_LDFLAGS)
+xz_LDADD = $(top_builddir)/src/liblzma/liblzma.la
if COND_GNULIB
-xz_LDADD += @top_builddir@/lib/libgnu.a
+xz_LDADD += $(top_builddir)/lib/libgnu.a
endif
+# libgnu.a may need these libs, so this must be after libgnu.a.
+xz_LDADD += $(LTLIBINTL)
+
## Create symlinks for unxz and xzcat for convenicen. Create symlinks also
## for lzma, unlzma, and lzcat for compatibility with LZMA Utils 4.32.x.