aboutsummaryrefslogtreecommitdiff
path: root/src/xz/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-02-07 21:17:07 +0200
committerLasse Collin <lasse.collin@tukaani.org>2009-02-07 21:17:07 +0200
commit880c3309386aac58fc4f3d7ca99bd31bcb1526a3 (patch)
treee96c422423cd0ba79e36df013de1f129d32135ec /src/xz/Makefile.am
parentadd gitignore files (diff)
downloadxz-880c3309386aac58fc4f3d7ca99bd31bcb1526a3.tar.xz
Make it easy to choose if command line tools should be
linked statically or dynamically against liblzma. The default is still to use static liblzma, but it can now be changed by passing --enable-dynamic to configure. Thanks to Mike Frysinger for the original patch. Fixed a few minor bugs in configure.ac.
Diffstat (limited to '')
-rw-r--r--src/xz/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/xz/Makefile.am b/src/xz/Makefile.am
index 5deed299..02dd8357 100644
--- a/src/xz/Makefile.am
+++ b/src/xz/Makefile.am
@@ -42,12 +42,10 @@ xz_CPPFLAGS = \
-I@top_srcdir@/src/common \
-I@top_srcdir@/src/liblzma/api \
-I@top_builddir@/lib \
- -I@top_srcdir@/lib
+ -I@top_srcdir@/lib \
+ @STATIC_CPPFLAGS@
-## Always link the command line tool statically against liblzma. It is
-## faster on x86, because no need for PIC. We also have one dependency less,
-## which allows users to more freely copy the xz binary to other boxes.
-xz_LDFLAGS = -static
+xz_LDFLAGS = @STATIC_LDFLAGS@
xz_LDADD = \
@top_builddir@/src/liblzma/liblzma.la \
@LTLIBINTL@