aboutsummaryrefslogtreecommitdiff
path: root/src/xz/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2010-10-08 15:25:45 +0300
committerLasse Collin <lasse.collin@tukaani.org>2010-10-08 15:25:45 +0300
commitb1c7368f95e93ccdefdd0748e04398c26766f47f (patch)
treefbba0f79912d7d009776a1b7e89b746677fbd8df /src/xz/Makefile.am
parentWindows: Make build.bash work without --enable-dynamic=no. (diff)
downloadxz-b1c7368f95e93ccdefdd0748e04398c26766f47f.tar.xz
Build: Add options to disable individual command line tools.
Diffstat (limited to '')
-rw-r--r--src/xz/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/xz/Makefile.am b/src/xz/Makefile.am
index e4ed59cf..10ceee75 100644
--- a/src/xz/Makefile.am
+++ b/src/xz/Makefile.am
@@ -69,7 +69,11 @@ dist_man_MANS = xz.1
## Create symlinks for unxz and xzcat for convenience. Create symlinks also
## for lzma, unlzma, and lzcat for compatibility with LZMA Utils 4.32.x.
-xzlinks = unxz xzcat lzma unlzma lzcat
+xzlinks = unxz xzcat
+
+if COND_LZMALINKS
+xzlinks += lzma unlzma lzcat
+endif
install-exec-hook:
cd $(DESTDIR)$(bindir) && \