aboutsummaryrefslogtreecommitdiff
path: root/src/scripts/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-07-05 22:25:17 +0300
committerLasse Collin <lasse.collin@tukaani.org>2009-07-05 22:25:17 +0300
commit96e4b257e101d72072d43e144897d92920270669 (patch)
tree5f1852c0c90b41b66dd0b24ba8719b68cea5d048 /src/scripts/Makefile.am
parentUse @PACKAGE_HOMEPAGE@ in liblzma.pc.in. (diff)
downloadxz-96e4b257e101d72072d43e144897d92920270669.tar.xz
Major update to the xzgrep and other scripts based on
the latest versions found from gzip CVS repository. configure will try to find a POSIX shell to be used by the scripts. This should ease portability on systems which have pre-POSIX /bin/sh. xzgrep and xzdiff support .xz, .lzma, .gz, and .bz2 files. xzmore and xzless support only .xz and .lzma files. The name of the xz executable used in these scripts is now correct even if --program-transform-name has been used.
Diffstat (limited to 'src/scripts/Makefile.am')
-rw-r--r--src/scripts/Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/src/scripts/Makefile.am b/src/scripts/Makefile.am
index 8ea5e2fa..8580ee5b 100644
--- a/src/scripts/Makefile.am
+++ b/src/scripts/Makefile.am
@@ -5,8 +5,8 @@
## You can do whatever you want with this file.
##
-dist_bin_SCRIPTS = xzdiff xzgrep xzmore
-dist_man_MANS = xzdiff.1 xzgrep.1 xzmore.1
+nodist_bin_SCRIPTS = xzdiff xzgrep xzmore xzless
+dist_man_MANS = xzdiff.1 xzgrep.1 xzmore.1 xzless.1
install-exec-hook:
cd $(DESTDIR)$(bindir) && \
@@ -22,9 +22,9 @@ install-exec-hook:
rm -f $$link && \
$(LN_S) $$target $$link; \
done && \
- target=`echo xzmore | $(SED) '$(transform)'` && \
- for name in xzless lzmore lzless; do \
- link=`echo $$name | $(SED) '$(transform)'` && \
+ for name in xzmore xzless; do \
+ target=`echo $$name | $(SED) '$(transform)'` && \
+ link=`echo $$name | $(SED) 's/xz/lz/;$(transform)'` && \
rm -f $$link && \
$(LN_S) $$target $$link; \
done
@@ -43,23 +43,23 @@ install-data-hook:
rm -f $$link.1 && \
$(LN_S) $$target.1 $$link.1; \
done && \
- target=`echo xzmore | $(SED) '$(transform)'` && \
- for name in xzless lzmore lzless; do \
- link=`echo $$name | $(SED) '$(transform)'` && \
+ for name in xzmore xzless; do \
+ target=`echo $$name | $(SED) '$(transform)'` && \
+ link=`echo $$name | $(SED) 's/xz/lz/;$(transform)'` && \
rm -f $$link.1 && \
$(LN_S) $$target.1 $$link.1; \
done
uninstall-hook:
cd $(DESTDIR)$(bindir) && \
- for name in xzcmp lzdiff lzcmp xzgrep xzegrep xzfgrep \
- lzgrep lzegrep lzfgrep xzless lzmore lzless; do \
+ for name in xzcmp lzdiff lzcmp xzegrep xzfgrep \
+ lzgrep lzegrep lzfgrep lzmore lzless; do \
link=`echo $$name | $(SED) '$(transform)'` && \
rm -f $$link; \
done
cd $(DESTDIR)$(mandir)/man1 && \
- for name in xzcmp lzdiff lzcmp xzgrep xzegrep xzfgrep \
- lzgrep lzegrep lzfgrep xzless lzmore lzless; do \
+ for name in xzcmp lzdiff lzcmp xzegrep xzfgrep \
+ lzgrep lzegrep lzfgrep lzmore lzless; do \
link=`echo $$name | $(SED) '$(transform)'` && \
rm -f $$link.1; \
done