aboutsummaryrefslogtreecommitdiff
path: root/src/lzma/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-11-19 20:46:52 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-11-19 20:46:52 +0200
commite114502b2bc371e4a45449832cb69be036360722 (patch)
tree449c41d0408f99926de202611091747f1fbe2f85 /src/lzma/Makefile.am
parentFixed the test that should have been fixed as part (diff)
downloadxz-e114502b2bc371e4a45449832cb69be036360722.tar.xz
Oh well, big messy commit again. Some highlights:
- Updated to the latest, probably final file format version. - Command line tool reworked to not use threads anymore. Threading will probably go into liblzma anyway. - Memory usage limit is now about 30 % for uncompression and about 90 % for compression. - Progress indicator with --verbose - Simplified --help and full --long-help - Upgraded to the last LGPLv2.1+ getopt_long from gnulib. - Some bug fixes
Diffstat (limited to '')
-rw-r--r--src/lzma/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/src/lzma/Makefile.am b/src/lzma/Makefile.am
index cd8bb771..e5c5c29a 100644
--- a/src/lzma/Makefile.am
+++ b/src/lzma/Makefile.am
@@ -15,19 +15,16 @@
bin_PROGRAMS = lzma
lzma_SOURCES = \
- alloc.c \
- alloc.h \
args.c \
args.h \
- error.c \
- error.h \
hardware.c \
hardware.h \
- help.c \
- help.h \
io.c \
io.h \
main.c \
+ main.h \
+ message.c \
+ message.h \
options.c \
options.h \
private.h \