aboutsummaryrefslogtreecommitdiff
path: root/src/liblzma/lzma/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-01-15 14:02:22 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-01-15 14:02:22 +0200
commite5728142a2048979f5c0c2149ce71ae952a092e1 (patch)
tree7ea154a3a970afecf25b5de654d9c915e9c0c84d /src/liblzma/lzma/Makefile.am
parentAdded bsr.h. (diff)
downloadxz-e5728142a2048979f5c0c2149ce71ae952a092e1.tar.xz
Revised the fastpos code. It now uses the slightly faster
table-based version from LZMA SDK 4.57. This should be fast on most systems. A simpler and smaller alternative version is also provided. On some CPUs this can be even a little faster than the default table-based version (see comments in fastpos.h), but on most systems the table-based code is faster.
Diffstat (limited to 'src/liblzma/lzma/Makefile.am')
-rw-r--r--src/liblzma/lzma/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/liblzma/lzma/Makefile.am b/src/liblzma/lzma/Makefile.am
index 48f3bb23..2d4a6ad7 100644
--- a/src/liblzma/lzma/Makefile.am
+++ b/src/liblzma/lzma/Makefile.am
@@ -12,6 +12,8 @@
## Lesser General Public License for more details.
##
+EXTRA_DIST = fastpos_tablegen.c
+
noinst_LTLIBRARIES = liblzma4.la
liblzma4_la_CPPFLAGS = \
-I@top_srcdir@/src/liblzma/api \
@@ -26,6 +28,8 @@ liblzma4_la_SOURCES = \
if COND_MAIN_ENCODER
liblzma4_la_SOURCES += \
+ fastpos.h \
+ fastpos_table.c \
lzma_encoder.h \
lzma_encoder.c \
lzma_encoder_presets.c \