aboutsummaryrefslogtreecommitdiff
path: root/src/liblzma/common/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-01-22 22:49:24 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-01-22 22:49:24 +0200
commitcf49f42a6bd40143f54a6b10d6e605599e958c0b (patch)
tree39cb9334863b938b34e208c2d89072dd447432cb /src/liblzma/common/Makefile.am
parentFix Multi-Block Stream encoder's EOPM usage. (diff)
downloadxz-cf49f42a6bd40143f54a6b10d6e605599e958c0b.tar.xz
Added lzma_easy_* functions. These should make using
liblzma as easy as using zlib, because the easy API don't require developers to know any fancy LZMA options. Note that Multi-Block Stream encoding is currently broken. The easy API should be OK, the bug(s) are elsewhere.
Diffstat (limited to '')
-rw-r--r--src/liblzma/common/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/liblzma/common/Makefile.am b/src/liblzma/common/Makefile.am
index 048f4c73..dad80ecd 100644
--- a/src/liblzma/common/Makefile.am
+++ b/src/liblzma/common/Makefile.am
@@ -70,6 +70,10 @@ libcommon_la_SOURCES += \
block_encoder.c \
block_encoder.h \
block_header_encoder.c \
+ easy_common.c \
+ easy_common.h \
+ easy_single.c \
+ easy_multi.c \
filter_flags_encoder.c \
init_encoder.c \
metadata_encoder.c \
@@ -80,6 +84,7 @@ libcommon_la_SOURCES += \
stream_common.h \
stream_encoder_single.c \
stream_encoder_multi.c \
+ stream_encoder_multi.h \
stream_flags_encoder.c \
vli_encoder.c
endif