aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2014-10-29 21:15:35 +0200
committerLasse Collin <lasse.collin@tukaani.org>2014-10-29 21:15:35 +0200
commitc923b140b27d1a055db6284e10fd546ad1a7fcdb (patch)
tree9be8130b208f7d44c7bdf014b005565a5d3834e5 /src/Makefile.am
parentTranslations: Update the Italian translation. (diff)
downloadxz-c923b140b27d1a055db6284e10fd546ad1a7fcdb.tar.xz
Build: Prepare to support Automake's subdir-objects.
Due to a bug in Automake, subdir-objects won't be enabled for now. http://debbugs.gnu.org/cgi/bugreport.cgi?bug=17354 Thanks to Daniel Richard G. for the original patches.
Diffstat (limited to '')
-rw-r--r--src/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9fb4caad..d199e858 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,4 +19,24 @@ if COND_SCRIPTS
SUBDIRS += scripts
endif
-EXTRA_DIST = common
+EXTRA_DIST = \
+ common/common_w32res.rc \
+ common/mythread.h \
+ common/sysdefs.h \
+ common/tuklib_common.h \
+ common/tuklib_config.h \
+ common/tuklib_cpucores.c \
+ common/tuklib_cpucores.h \
+ common/tuklib_exit.c \
+ common/tuklib_exit.h \
+ common/tuklib_gettext.h \
+ common/tuklib_integer.h \
+ common/tuklib_mbstr_fw.c \
+ common/tuklib_mbstr.h \
+ common/tuklib_mbstr_width.c \
+ common/tuklib_open_stdxxx.c \
+ common/tuklib_open_stdxxx.h \
+ common/tuklib_physmem.c \
+ common/tuklib_physmem.h \
+ common/tuklib_progname.c \
+ common/tuklib_progname.h