aboutsummaryrefslogtreecommitdiff
path: root/debug/Makefile.am
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-01-18 20:18:08 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-01-18 20:18:08 +0200
commit61dc82f3e306b25ce3cd3d529df9ec7a0ec04b73 (patch)
treecdc13dd318a6a3f34771a4acfc4f15cc5f6fdab5 /debug/Makefile.am
parentAdded test files to test usage of flush marker in LZMA. (diff)
downloadxz-61dc82f3e306b25ce3cd3d529df9ec7a0ec04b73.tar.xz
Added the debug directory and the first debug tool
(sync_flush). These tools are not built unless the user runs "make" in the debug directory.
Diffstat (limited to 'debug/Makefile.am')
-rw-r--r--debug/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/debug/Makefile.am b/debug/Makefile.am
new file mode 100644
index 00000000..b393db3e
--- /dev/null
+++ b/debug/Makefile.am
@@ -0,0 +1,30 @@
+##
+## Copyright (C) 2008 Lasse Collin
+##
+## This library is free software; you can redistribute it and/or
+## modify it under the terms of the GNU Lesser General Public
+## License as published by the Free Software Foundation; either
+## version 2.1 of the License, or (at your option) any later version.
+##
+## This library is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## Lesser General Public License for more details.
+##
+
+noinst_PROGRAMS = \
+ sync_flush
+
+AM_CPPFLAGS = \
+ -I@top_srcdir@/src/common \
+ -I@top_srcdir@/src/liblzma/api
+
+AM_LDFLAGS = -static
+
+LDADD = \
+ @top_builddir@/src/liblzma/liblzma.la \
+ @LTLIBINTL@
+
+if COND_GNULIB
+LDADD += @top_builddir@/lib/libgnu.a
+endif