aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2013-04-27 22:07:46 +0300
committerLasse Collin <lasse.collin@tukaani.org>2013-04-27 22:07:46 +0300
commit97379c5ea758da3f8b0bc444d5f7fa43753ce610 (patch)
tree72eb320aadb7b81d5b9caa1c72f9283e4275f1ff /configure.ac
parentxzdec: Improve the --help message. (diff)
downloadxz-97379c5ea758da3f8b0bc444d5f7fa43753ce610.tar.xz
Build: Use -Wvla with GCC if supported.
Variable-length arrays are mandatory in C99 but optional in C11. The code doesn't currently use any VLAs and it shouldn't in the future either to stay compatible with C11 without requiring any optional C11 features.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fa186e26..b52eb662 100644
--- a/configure.ac
+++ b/configure.ac
@@ -653,6 +653,7 @@ if test "$GCC" = yes ; then
for NEW_FLAG in \
-Wall \
-Wextra \
+ -Wvla \
-Wformat=2 \
-Winit-self \
-Wmissing-include-dirs \