aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-11-20 12:51:19 +0200
committerLasse Collin <lasse.collin@tukaani.org>2009-11-20 12:51:19 +0200
commitc74c132f7f79a842c073c66575a4fdb985e4c2e3 (patch)
treec8982faab86370e737363d096354529feff87022 /configure.ac
parentAdd support for --info-memory and --robot to xz. (diff)
downloadxz-c74c132f7f79a842c073c66575a4fdb985e4c2e3.tar.xz
Update tuklib_cpucores.m4 and tuklib_physmem.m4 from tuklib,
which now use AC_CACHE_CHECK. Using the cache variable, configure now warns if there is no method to detect the amount of RAM and recommends using --enable-assume-ram.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 82a7b1f9..aa05ba4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -681,3 +681,19 @@ AC_CONFIG_FILES([
])
AC_OUTPUT
+
+# Some warnings
+if test x$tuklib_cv_physmem_method = xunknown; then
+ echo
+ echo "WARNING:"
+ echo "No supported method to detect the amount of RAM."
+ echo "Consider using --enable-assume-ram (if you didn't already)"
+ echo "or make a patch to add support for this operating system."
+fi
+
+# Not threading yet so don't warn.
+#if test x$tuklib_cv_cpucores_method = xunknown; then
+# echo
+# echo "WARNING:"
+# echo "No supported method to detect the number of CPU cores."
+#fi