aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-02-02 21:19:01 +0200
committerLasse Collin <lasse.collin@tukaani.org>2009-02-02 21:19:01 +0200
commit99c1c2abfae2e87f3c17e929783e6d1bb7a3f302 (patch)
treef4a8b3bb49469a1d25853f901ba2a24e3fcf5c8e /configure.ac
parentModify LZMA_API macro so that it works on Windows with (diff)
downloadxz-99c1c2abfae2e87f3c17e929783e6d1bb7a3f302.tar.xz
Updated the x86 assembler code:
- Use call/ret pair to get instruction pointer for PIC. - Use PIC only if PIC or __PIC__ is #defined. - The code should work on MinGW and Darwin in addition to GNU/Linux and Solaris.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 39996bcc..afd5afc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,12 +307,6 @@ if test "x$enable_assembler" = xyes; then
x86_64) enable_assembler=x86_64 ;;
*) enable_assembler=no ;;
esac
- # Darwin has different ABI than GNU+Linux and Solaris,
- # and the assembler code doesn't assemble.
- case $host_os in
- darwin*) enable_assembler=no ;;
- *) ;;
- esac
fi
case $enable_assembler in
x86)