aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2015-11-03 20:29:33 +0200
committerLasse Collin <lasse.collin@tukaani.org>2015-11-03 20:29:33 +0200
commitcb3111e3ed84152912b5138d690c8d9f00c6ef02 (patch)
treea706e5bcb842a342b8e3290e5b961e15467ee3c8 /configure.ac
parentBuild: Build LZMA1/2 presets also when only decoder is wanted. (diff)
downloadxz-cb3111e3ed84152912b5138d690c8d9f00c6ef02.tar.xz
xz: Make xz buildable even when encoders or decoders are disabled.
The patch is quite long but it's mostly about adding new #ifdefs to omit code when encoders or decoders have been disabled. This adds two new #defines to config.h: HAVE_ENCODERS and HAVE_DECODERS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb554442..cb6eac98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,8 @@ else
;;
esac
done
+ AC_DEFINE([HAVE_ENCODERS], [1],
+ [Define to 1 if any of HAVE_ENCODER_foo have been defined.])
AC_MSG_RESULT([$enable_encoders])
fi
@@ -141,6 +143,8 @@ else
;;
esac
done
+ AC_DEFINE([HAVE_DECODERS], [1],
+ [Define to 1 if any of HAVE_DECODER_foo have been defined.])
AC_MSG_RESULT([$enable_decoders])
fi