aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-01-09 20:05:57 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-01-09 20:05:57 +0200
commit382808514a42b2f4b4a64515e2dfb3fc1bc48ecd (patch)
tree6ea0fa5a238af7cbdcda0bbaf2832ca05dcc84d4 /configure.ac
parentAdded good-single-none-empty_3.lzma and (diff)
downloadxz-382808514a42b2f4b4a64515e2dfb3fc1bc48ecd.tar.xz
Define HAVE_ASM_X86 when x86 assembler optimizations are
used. This #define will be useful for inline assembly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 83a8c665..daa87d0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -316,7 +316,10 @@ if test "x$enable_assembler" = xyes; then
esac
fi
case $enable_assembler in
- x86|no) ;;
+ x86|no)
+ AC_DEFINE([HAVE_ASM_X86], 1,
+ [Define to 1 if using x86 assembler optimizations.])
+ ;;
*)
AC_MSG_RESULT([])
AC_MSG_ERROR([--enable-assembler accepts only \`yes', \`no', or \`x86'.])