aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2015-11-03 20:29:33 +0200
committerLasse Collin <lasse.collin@tukaani.org>2016-06-28 21:09:46 +0300
commit2296778f3c9a1e3a8699973b09dd3610b8baa402 (patch)
tree3055efca9963794a43a86503d3ffe12a398c4b98 /configure.ac
parentBuild: Build LZMA1/2 presets also when only decoder is wanted. (diff)
downloadxz-2296778f3c9a1e3a8699973b09dd3610b8baa402.tar.xz
xz: Make xz buildable even when encoders or decoders are disabled.
The patch is quite long but it's mostly about adding new #ifdefs to omit code when encoders or decoders have been disabled. This adds two new #defines to config.h: HAVE_ENCODERS and HAVE_DECODERS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58428820..26b6f703 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,8 @@ else
;;
esac
done
+ AC_DEFINE([HAVE_ENCODERS], [1],
+ [Define to 1 if any of HAVE_ENCODER_foo have been defined.])
AC_MSG_RESULT([$enable_encoders])
fi
@@ -141,6 +143,8 @@ else
;;
esac
done
+ AC_DEFINE([HAVE_DECODERS], [1],
+ [Define to 1 if any of HAVE_DECODER_foo have been defined.])
AC_MSG_RESULT([$enable_decoders])
fi