aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2008-01-15 13:29:14 +0200
committerLasse Collin <lasse.collin@tukaani.org>2008-01-15 13:29:14 +0200
commitf3c88e8b8d8dd57f4bba5f0921eebf276437c244 (patch)
tree965faebcc5e9ffa629fd6e36f99d85b2a96e4b3a /configure.ac
parentOmit invalid space from printf() format string (diff)
downloadxz-f3c88e8b8d8dd57f4bba5f0921eebf276437c244.tar.xz
Fixed assembler detection in configure.ac, and added
detection for x86_64.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 16 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index daa87d0d..0a5c5dd7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -298,28 +298,28 @@ AC_ARG_ENABLE(assembler, AC_HELP_STRING([--disable-assembler],
[], [enable_assembler=yes])
if test "x$enable_assembler" = xyes; then
case $host_cpu in
- i?86)
- # Darwin has different ABI than GNU+Linux and Solaris,
- # and the x86 assembler code doesn't assemble.
- case $host_os in
- darwin*)
- enable_assembler=no
- ;;
- *)
- enable_assembler=x86
- ;;
- esac
- ;;
- *)
- enable_assembler=no
- ;;
+ i?86) enable_assembler=x86 ;;
+ x86_64) enable_assembler=x86_64 ;;
+ *) enable_assembler=no ;;
+ esac
+ # Darwin has different ABI than GNU+Linux and Solaris,
+ # and the assembler code doesn't assemble.
+ case $host_os in
+ darwin*) enable_assembler=no ;;
+ *) ;;
esac
fi
case $enable_assembler in
- x86|no)
+ x86)
AC_DEFINE([HAVE_ASM_X86], 1,
[Define to 1 if using x86 assembler optimizations.])
;;
+ x86_64)
+ AC_DEFINE([HAVE_ASM_X86_64], 1,
+ [Define to 1 if using x86_64 assembler optimizations.])
+ ;;
+ no)
+ ;;
*)
AC_MSG_RESULT([])
AC_MSG_ERROR([--enable-assembler accepts only \`yes', \`no', or \`x86'.])