aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLasse Collin <lasse.collin@tukaani.org>2009-05-02 16:10:14 +0300
committerLasse Collin <lasse.collin@tukaani.org>2009-05-02 16:16:28 +0300
commita6f43e64128a6da5cd641de1e1e527433b3e5638 (patch)
tree156bb6c72df23cbe0864e293456fc217c652d22d /configure.ac
parentRemoved --disable-encoder and --disable-decoder. Use the values (diff)
downloadxz-a6f43e64128a6da5cd641de1e1e527433b3e5638.tar.xz
Use a GCC-specific #pragma instead of GCC-specific
-Wno-uninitialized to silence a bogus warning.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 2df36e56..c9676cf8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -534,8 +534,6 @@ lc_CPUCORES
# If using GCC, set some additional AM_CFLAGS:
###############################################################################
-Wno_uninitialized=no
-
if test "x$GCC" = xyes ; then
echo
echo "GCC extensions:"
@@ -544,15 +542,6 @@ if test "x$GCC" = xyes ; then
AM_CFLAGS="$AM_CFLAGS $CFLAG_VISIBILITY"
fi
- # -Wno-uninitialized is needed with -Werror with SHA256 code
- # to omit a bogus warning.
- AC_MSG_CHECKING([if $CC accepts -Wno-uninitialized])
- OLD_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -Wno-uninitialized"
- AC_COMPILE_IFELSE([void foo(void) { }], [Wno_uninitialized=yes])
- CFLAGS="$OLD_CFLAGS"
- AC_MSG_RESULT([$Wno_uninitialized])
-
# Enable as much warnings as possible. These commented warnings won't
# work for this package though:
# * -Wunreachable-code breaks several assert(0) cases, which are
@@ -608,8 +597,6 @@ if test "x$GCC" = xyes ; then
fi
fi
-AM_CONDITIONAL([COND_WNO_UNINITIALIZED], test "x$Wno_uninitialized" = "xyes")
-
###############################################################################
# Create the makefiles and config.h